how to play asx files

Hello,

I was trying to listen to a radio station (download the asx file) but I cannot pay that file with any of my applications.

Could you recommend me some extensions to install in order to play that kind of files. Notice that the stream is wma formated.

I’m using openSUSE 11.2 with KDE.

Nuca

Both vlc and mplayer (smplayer as frontend) should work.

They are available in the packman repository (do not use vlc repo and packman at the same time - I suggest just to use packman).

For mplayer install the codec package as well.

See this: Additional package repositories - openSUSE

Restricted Formats/11.2 - openSUSE-Community

Cheers.

I tried with VLC to open the asx file. It opens the file, buffers it but when it comes to play it … it doesn’t play.
Am I missing something else?

After confirming you have the required codecs, right-clicking on the broadcast link and selecting one of the “open with” provisions instead of attempting to download might do the trick too.

Can your vlc play any other files?

Do you have a packman packaged vlc or do you have a vidoeolan packaged vlc ?

Do you have a packman packaged libffmpeg0/ffmpeg or do you have a videlolan packaged libffmpeg0/ffmpeg ?

Another caution here … some web sites, as soon as they determine it is a Linux system trying to access their stream, will deliberately stop the stream.

I tried to open a mp3 to play and indeed VLC didn’t play this file. I don’t have any other audio files on my system to check other formats.

After that I removed my previous version of VLC (it think it was downloaded from VLC site) and installed again from YAST also I check to see if libffmpeg0/ffmpeg are installed and indeed they are installed but still doesn’t play any file.

Multi-media and Restricted Format Installation Guide - openSUSE Forums

I have to run to a meeting, but here is a copy and paste of an earlier post of mine.

In part because of the tremendous flexibility offered with openSUSE Linux, it has also meant there is tremendous room for a misconfiguration that causes the appearance of non-functionality.

Wrt codecs, there is no 100% agreed standard (unfortunately) and hence not all packagers put codecs in the same place that the various multimedia applications can find them. Hence if you were to install codecs from videolan/libdvdcss repositories, there may be various Packman packaged (and Novell packaged) applications may not find them, and hence no sound or possibly no video with an application, even though the codecs are in place.

Thus to avoid this risk (and also for other reasons) I always recommend new users stick to having only the 3 official Novell/SuSE-GmbH repositories (OSS, Non-OSS, and Update) and one and only one 3rd party repository, Packman. No others. Just those 4: OSS, Non-OSS, Update and Packman. There is guidance here for that: Repositories/11.2 - openSUSE-Community . Avoid the temptation to add more than those 4 !! Users with lots of openSUSE experience under their belt can add and keep in place more than those 4. New/average users can not. So just those 4. IF you need an application from a 5th repository which is not one of those 4, then add the 5th repository, add the application, and disable or remove the 5th repository. [An example of this is to install libdvdcss from videolan]. Keep your repositories LEAN and MEAN. IMHO the best way to solve a repository dependency/functionality problem is to never encounter one.

Now typically the desktops and multimedia applications in openSUSE give one the choice of choosing a different sound engine. I prefer to use xine as my sound engine. Hence I always install the Packman packaged version of libxine1 (provides the sound engine) and xine-ui (provides the user interface for tuning the engine). In xine with xine-ui one can then go to settings, switch to “master of the known universe”, restart xine, and go to xine settings and fine tune the audio api selection. Also, then in KDE I ensure under Configure Desktop > Multimedia I have the xine back end selected.
Users with multiple sound devices need to ensure settings in KDE > Configure Desktop > Multimedia are consistent with the priority of devices in YaST > Hardware > Sound.

Good media players that I like to use are vlc and smplayer. Other players such as kaffeine and of course xine (with xine-ui) can be used.

Note in each media player, one can go and tune the audio backend. Or if there is no backend tune option, then one typically needs to tune via their desktop’s tuning options.

In cases where a user has already installed a bunch of videolan repository packaged apps, to avoid the compatibility problems that I noted, I typically recommend users then switch all of those videolan packaged apps to Packman packaged apps (where there is a “pm” in the version number). This is very easy to do in openSUSE-11.2 with the qt version of YaST (unfortunately I don’t see that same switch repository option in the Gnome gtk based version).

Thanks a lot!

Now it’s working! It was a compatibility problem with the packages.

Thanks again to all!

To play ASX, you need a professiona ASX Player as players like VLC, WMP, QuickTime do not support playing ASX files at all.

You may type Cicever ASX Player in Goolge to get it. In addition, it can also convert ASX to MP4, WMV, AVI, MP3, FLV etc.