how to make wlan0 start automatically?

so i have finally found the right driver for my rtl8187b wireless card (i used this link “What I did on my vacation from reality » RTL8187B drivers and patches”)

but now this is what i must do every time i login!

su
cd /home/tj/rtl8187b-modified
./wlan0up

in Ubuntu i could add this to my /etc/rc.local


/home/tj/rtl8187b-modified/wlan0up
ifconfig wlan0 up
dhclient wlan0
exit 0

opensuse doesnt seem to have an /etc/rc.local

so my question is what can i do to make my wireless start automatically?

is there another file that i can add those lines to?

Just use the knetworkmanager and configure that to connect automatically.

i don’t see the knetworkmanager anywhere in yast package manager

is it availible for gnome?

You need to use the gnome equiv…
NetworkManager-gnome

ok i dont think this idea is going to work

my network manager is already configured to auto connect and everything

the problem is that wlan0 isnt even recognized as a device until after i run the ./wlan0up script

heres the contents of wlan0up


#!/bin/bash

if test "`dirname $0`" != ".";
then
	cd `dirname $0`
fi

SYSTEM=`uname -r|cut -d. -f1,2`

if  $SYSTEM = 2.4 ]
then
cd ieee80211
insmod ieee80211_crypt-rtl.o
insmod crypto-rtl.o
insmod michael_mic-rtl.o
insmod aes-rtl.o
insmod ieee80211_crypt_wep-rtl.o
insmod ieee80211_crypt_tkip-rtl.o
insmod ieee80211_crypt_ccmp-rtl.o
insmod ieee80211-rtl.o

cd ../rtl8187
insmod r8187.o

else
cd ieee80211/
insmod ieee80211_crypt-rtl.ko
insmod ieee80211_crypt_wep-rtl.ko
insmod ieee80211_crypt_tkip-rtl.ko
insmod ieee80211_crypt_ccmp-rtl.ko
insmod ieee80211-rtl.ko

cd ../rtl8187/
insmod r8187.ko $@
fi

cd ../

/etc/init.d/boot.local (put in the line “ifup wlan0”)
Also, check in Yast that you have it ticked to start at boot

it worked!

thank you

Ok i spoke too soon

today i rebooted my computer and i noticed that the boot time is outrageously long

i booted with with no splash so i could see what was happening

as soon as /etc/init.d/boot.local gets loaded there are a bunch of lines that look like this

DHCP Request blah blah blah blah
DHCP Request blah blah blah blah
DHCP Request blah blah blah blah
DHCP Request blah blah blah blah
DHCP Request blah blah blah blah
DHCP Request blah blah blah blah
DHCP Request blah blah blah blah
DHCP Request blah blah blah blah
(blah blah blah blah is actuall like adresses and stuff obviously)

(i dont have a digital camera so i cant get a picture)

then after about 40-60 seconds it will say DHCP failed and it will continue to boot

when it finishes loading up the desktop my wireless works fine
(it just sucks that it takes an extra minute to boot, and its not necessary)

so what can i do now?

i have heard something about moving the modules into a certain directory so that they get loaded automatically but how would i go about doing this?
and how would i get ifconfig wlan0 up and dhclient wlan0 to run?

See what happens if you change the setting from “start at boot” to “start manually” but leave the “ifup wlan0” line in /etc/init.d/boot.local.

I’m hoping the line “ifup wlan0” will trigger all that dhcp stuff at a later time, although I’m really not sure – try it.

See what happens if you change the setting from “start at boot” to “start manually”

im confused, where is this setting?

Yast → net devices → net settings → highlight the interface → edit → general → activate device → manually

hmm…

i just tried that but it still didn’t work

i even tried setting a static ip but that doesnt work either

it returns an error (something about set nickname failed operation not permitted)

is there a system log or something that records what i see at boot?

that way i could just post the errors it is giving me

Open YaST > Miscellaneous > System Log (or Start-Up Log)