How to make text higher contrast?

Text is somewhat hazy. This is in normal applications, web pages. How to make text get higher contrast? Tumbleweed KDE

](https://ibb.co/4ddDqLC)https://i.ibb.co/m88YjKd/text-has-less-contrast.png

This is about the browser you use? You do not tell which browser. And when it is about another application, you do not tell what application. In any case, did you check the configuration possibilities of the browser (or application)?

Hi, not easy to judge from the image you posted, but I guess that you don’t suffer for “contrast” (i.e. make white whiter and black darker) but for “blur” or maybe subpixel rendering if you are using an LCD screen.
You may try the options available in SystemSettings > Appearance-Fonts, try to disable anti-aliasing or change a sub-pixel rendering option.
Or maybe you are not using the native resolution for your display, try another option in Display and Monitor > Resolution.
You may also try another option for Compositor, but we need a better description of what you see and in what applications to be of further help, e.g. open Konsole and see if the terminal output is blurred, tell which browser you use and what web pages don’t render properly (if it makes any difference at all…).

You’re right in that case, but also bad-web-masters are often using text with lower contrast, i.e not B&W, but grey on grey. You can check it in FF: select text, open context menu, tab “Explore”, check color palette of a text.

Sorry, I was out for a while.
I used few web browsers to check, Firefox, MS Edge and Opera. But, you see Dolphin prominently, on top of the web page. Text in it too were hazy. This was after an update.
I change the compositor Scale method to crisp, and Rendering backend to openGl 3.1, now the text is somewhat alright. Not as crisp as it was before. If I disable anti-aliasing the text is broken. I have Intel Iris graphics.

Global theme is Breeze Dark, plasma style is Breeze, application style is Breeze, Colours is Breeze Dark etc, nothing was changed, except the dark theme. I have checked with the Arch KDE installation, there the text is very clear.

This is the same with Kate, Konsole, Dolphin etc, in every app.

Kinfo

https://i.ibb.co/GWyHjmF/kinfo.png](https://ibb.co/y6t4J2V)

You see, even the screenshot’s text is hazy.

Recent updates included Plasma-Framework and Mesa. If you have also another Desktop Environment installed, it would be interesting to know if you see the same effect there (same Mesa but no Plasma…).
You might also check with a Gnome or Rescue LiveDVD instead of installing another DE.
Or you may disable sub-pixel rendering (Sub-pixel rendering > none , hinting > none in System settings > Fonts) just in case you are seeing something similar to 1172022 – Ugly fonts after install: openSUSE-2020-704 - Security update for freetype2

Checked the new Mesa with Gnome and no problems here on Haswell Mobile graphics, so seems something related to Plasma or HW / configuration.

I read that bug report, thanks.
Sub-pixel rendering cannot be set to anything, for it doesn’t get saved. It turns back to “slight.”

When I click on “Force font DPI” the text sort of become good. I didn’t change the DPI value there, which is 96. If I change it to more, the web sites don’t work well at 100%. But, in other KDE distros, when the display resolution increased to 150%, as here, the DPI goes up to 144. No idea, what’s the matter, but I can see the text well now. Hope, it’d get corrected in future updates. :slight_smile:

The correct value of DPI depends on the monitor you use, just divide the total number of pixels (say, 1920) by the length of the side of your monitor (say, 13.33 in) and you get 144 Dot Per Inch as in the FHD 15" screen I’m using to write this.
Most screens should inform the OS about their DPI via EDID, but sometimes that information is not sent and you have to “force” the correct value to have the best display of your desktop.
I cannot comment on the current behaviour of Plasma at the moment, but it is definitely possible that an update garbled some old configuration and your action simply overwrote the config with a correct value even if you didn’t change the value itself.

Apparently if you check the “Force DPI” box when you are at 96 DPI and 100% display scaling, when you change display scaling to 150% you will see DPI “forced” to 144 like you see in other distros.
Maybe a different sequence or an old user config can cause a conflict.
But if you are OK now, as the old saying tells “If it ain’t broken, don’t fix it”.