How to make laptop primary monitor in 11.3

Hi everyone,

I installed openSUSE 11.3 on my Dell studio laptop with Mobility Radeon HD 4500 graphics card and everything worked straight out of the box.

Now… I am connecting my tv through HDMI cable as second monitor. Basically I just want to play movies on my tv while still having the laptop screen free to work. This also works, I just plugged it in and I had two screens.

My problem is that my tv is the primary monitor so basically my laptop background (and all the buttons that go with it) moves to the tv and my laptop background is just a background. See attached image at the bottom of this post(Laptop on the left and tv on the right).

This is exactly what I want but the other way around. I can’t seem to change this in System Settings/Display. Is there a file somewhere I can change this??

Many thanks

ImageBam - Fast, Free Image Hosting and Photo Sharing

Are you using the proprietary fglrx driver, or the radeon driver?

If the latter, you could try ‘xrandr’ to get your display device names (eg LVDS and DVI-0). Then try

xrandr --output LVDS --primary

For more options

xrandr --help


I’m using the radeon driver. The device names + info do apear when I type ‘xrandr’, so I think your advice might do the trick. I will try it when I get home.

I’m not sure about this, but AFAIU KDE4 may have a constraint with the primary monitor needing to be the ‘right’ positioned screen. I can’t test this, as I don’t have a second monitor to play with at the moment.

If you get the desired result, and want to make the change stick, you’ll either have to put the xrandr command in a startup script (to be executed on login), or statically configure with xorg.conf. Just an example:

Section "Monitor" #laptop monitor
    Identifier  "LVDS"
    Option       "PreferredMode" "1280x800"

Section "Monitor" #external monitor
       Identifier   "VGA-0"
       Option       "DPMS"
       Option       "PreferredMode" "1440x900"
       Option       "LeftOf"  "LVDS"
       Option       "Position"      "1280 0"

Section "Device"
        Identifier  "Card0"
    Driver      "radeon"
    VendorName  "ATI Technologies Inc"
    BoardName   "RC410 [Radeon Xpress 200M]"
    Option          "monitor-LVDS" "LVDS"
    Option          "monitor-VGA" "VGA-0"

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "LVDS" 
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Virtual 2720 900

More info from man radeon

BTW, you can put xrandr commands within your user .profile like this:

dean@linux-8dcq:~> cat /home/dean/.profile
# Sample .profile for SuSE Linux
# rewritten by Christian Steinruecken <>
# This file is read each time a login shell is started.
# All other interactive shells will only read .bashrc; this is particularly
# important for language settings, see below.

test -z "$PROFILEREAD" && . /etc/profile || true

#Setup preferred display mode with xrandr
xrandr --output LVDS --mode 1280x800

This will only take effect once logged in of course.

I’ve got this same problem only with the proprietary drivers. Radeon drivers keeps my notebook screen as the primary.

The proprietary drivers have their own configuration tools. I’m now using the open source radeon driver with 11.3, so I can’t offer as much help as I’d like. Hopefully others will assist if they can.

The aticonfig utility can be used to create/adjust xorg.conf if necessary. For various options:

aticonfig --help

It also offers some ‘xrandr-like’ options for making changes immediately as well. For example:

aticonfig --query-monitor

to see what is attached. To swap two display devices around:

aticonfig --swap-monitor --effective=now

A good reference on this:

Configuring -

For xorg.conf configuration info, this may be useful:

X.Org/Dual Monitors/ATI - Gentoo Linux Wiki

In particular, you may need to specify an option like this:

Option “MonitorLayout” “LVDS,AUTO” - This is for a laptop, it sets the first display to be in the internal LCD (LVDS), and to auto-detect the second display.

The Ati Catalyst Control Centre ‘amdcccle’ graphical utility may also be helpful. I haven’t used it for a long time, so I’ll leave that for you to experiment with.

BTW, I have read this Ubuntu thread which suggests that it is possible (for Gnome desktop users) to configure the montior preferences with amdcccle, then navigate to System->Preferences->Screen Resolution and save settings which will survive a reboot.