How to make extended partitions during install?

I am completely stumped. I am trying to build a system with

/boot/efi (fat, 500MB)
/ (ext4, 24GB)
swap (12GB)
/home (ext4, 24GB)
/data (ext4, *)

That’s 5, so I need to put /home and /data into an extended partition setup. Is there a way at TW installation time? I tried manually entering part type 0x5, but it SILENTLY changes it to part type 0x7 (ntfs). I must be missing something. It asks about primary vs extended on a USB stick, but not for the SSD drive.

I’m going to try zeroing out the beginning of the ssd, and rebooting the installer in legacy mode.

Done, okay well in non-UEFI mode, it doesn’t demand /boot/efi, so then I only need 4 partitions, and the problem doesn’t even exist. Not sure why the other mode demands /boot/efi and a FAT partition on a Linux system.

Okay, a GPT disk is supposed to allow 128 partitions. Why did it limit me to 4? Or if it was still in MBR mode, why didn’t it offer primary or extended? Somewhere, something isn’t quite right imo.

My assumption is that GPT + UEFI mode would be the best choice going forward, but I need 5 partitions in that case.

Drop to console (ALT+F2)
dd zeros 1MB to disk
cfdisk -> choose gpt, write, exit
Return to gui (ALT+F7)
rescan devices, now it’s in GPT mode, add 5+ partitions no problem

No idea how the casual Linux user would fair!

Choosing “ext4” as default has no effect, it still defaults to XFS regardless.

Well that resulted in a non-booting TW installation (Ryzen 1500X + Asus Prime B350M-A/CSM). I’ve never had such a tough time installing openSUSE in years!

Now the installer won’t launch because there is something on the sdd. I’m gonna have to use a different distro to wipe the sdd part table, this is insanity.

I beat the partition tables into submission. Next issue,

Are GTX 650Ti and GTX 760 now unsupported? They just flicker the login screen for 1/2 second, then go blank. I had to use a GTX 1060 to get a usable login screen.

Installed nvidia 481.09 beta (for kernel 4.10) and stuck the GTX 650Ti back in, works like a champ. Finally, a working install after 4 hours!!! Maybe I better upgrade to GTX 1050 card, if 650 is being deprecated in nouveau support. The 1060 was borrowed from another workstation.

The “year of the Linux desktop” is apparently very, very far away.

I hope you will understand that you probably will not get a real answer from others here.

Your string of posts, counter posts, self answering posts, etc. makes it very difficult to see if you still have a problem, and when yes what it is (and if it is still covered by the thread title).

In any case, when it is really that problematic to create ones own partition setup at installation, there would be more, much more threads about that here on the forums. The partitioning part of the installer has enough possibilities to deviate from the partitioning offered, by editing yourself, going for a complete different setup from scratch with one click, etc.

In other words, as long as you do not explain what you tried where in the installer. or how and with what tool you tried to “manually entering part type 0x5” (just some examples of your vague descriptions), others might feel it very difficult to comment.

Haha yah I know, it was a frustrating stream of consciousness.

Basically, the 250GB evo SSD as provided by Samsung out-of-the-box confused the installer. The installer would not allow extended partitions w/MBR, nor would it allow more than 4 partitions with GPT. Once I zeroed out the beginning of the disk, it behaved better.

Another issue I ran into is that the installer supports 1050Ti but not 650Ti. But the rescue iso supports 650Ti but not 1050Ti.

I’ve been using Linux for 20 years. The issues I’m hitting are real. Don’t know what to tell you.

EFI is the new boot method and only works on GPT partitioned drives you don’t need an extended and it is not supported. Which boot mode that the install defaults to is determined by how it is booted ie MBR or EFI mode. With EFI a it is required to have a special partition as the EFI boot partition. This is small (under 100 meg and FAT formatted, It is just the EFI spec has nothing to do with Linux per-say just needed by the EFI boot. You can set up a MBR boot on a GPT partitioning but not a EFI boot on DOS partitioning

Yes, I used GPT and EFI and 5 partitions, but that wasn’t the problem. The problem was that no way, no how, would the installer let me make 5 partitions in MBR or GPT mode, unless I zeroed out the first few ssd blocks. Somewhere there is a bug in the installer. Too bad that I did not save those sectors. Someone has to order a new 250GB Samsung evo to find out.

sda1 efi
sda2 root (24GB)
sda3 swap
sda4 home
sda5 backup

Basically I boot rescue iso, and dd (from 0) the sda blocks covering through sda2 into a gz file on backup, before zypper dup. It’s a work machine, and it HAS to work. So if I get a bad update, then I can dump a perfect image of a previously working system onto the head of the ssd. I only update once a month. It all works out.

MBR is a boot method not a partitioning method the old DOS partitioning used MBR booting. You should be able to use MBR boot on a GPT partitioned system if you use legacy mode set in the UEFI (AKA BIOS) but that may depend on the the particular UEFI. In any case it is best to use EFI boot on a UEFI machine and thus use GPT partitioning unless you need to support older setups that are DOS partitioned based Also it is possible that the drive came with both GPT and DOS partition tables which may have confused things since hybrid is possible. :\

Ahh, thanks. (Yah you know what I meant when I said “mbr partitioning”, the old classic pre-GPT style with 4 primary partition limitation.) I’ll have to read up on the hybrid dual partition table monster, I didn’t know that was possible. Probably what the problem was then. Thanks!