How to make compiled kernel work in 11.0?

Hi All.

I am expiriencing troubles with 11.0 that I haven’t expirienced before with all other versions.

First, I have discovered that mkinitrd, the one comes with suse 11.0 is seriously bad, as it screws up initrd completely, generating error 23, immediately on boot.
OK, I replaced it with the one from 10.3 and didnt recieved any errors of that kind.

But then, I cannot make compiled kernel work. It starts loading, screen goes black and it hangs there forever.
I even downloaded new kernel, same thing.

Are there any secrets that I should know about? As I am 1st time having laptop. On my desktop with 10.3 and old athlon, no problems whatsoever, and I compiled kernel more than dozen times over the years.

I have ASUS Pro50 with Dual-Core intel, 1.66 GHz, 2 MB Ram, X2300 ATI

There are also few questions below that I have.

  1. what should be compile parameters for this processor? I have used none and same effect (not working), as if I use:
    CFLAGS="-pipe -O2 -fomit-frame-pointer -mtune=core2"
    CXXFLAGS the same as above

  2. In kernel, processor type should be “Pc-compatable” with “Core2 / newer Xeon” ? Is this correct?

Well, I do not know where else to look for the problem. I need to compile the kernel as Atheros driver is not included in generic and I am having some problems with ndiswrapper

Any help is greatly appreciated.

Thread moved to Applications

Anyone knows at least any part of the post?


what kernel source do you use and how configured?
is the default kernel running ok?

options seems ok but can try with
CFLAGS="-pipe -O2 -fomit-frame-pointer -march=core2"
CXXFLAGS the same as above

Thanks for input about flags.

Default installed (pre-compiled) kernel works OK (except I do not have atheros driver).
However, whatever I compile, does not work.

With default mkinitrd was a disaster immediately. Now with mkinitrd from 10.3, it starts loading, but black screen and lockups occur.

I tried with default kernel source and new 2.6…25 kernel, separately downloaded from The Linux Kernel Archives

Compile options… more or less default, changed only processor type to Pc-Compatable and sub: Core2/Xeon, and unchecked all I am certain that I do not have.

if you wish, I may post .config later this evening when I get home.


well, you didin’t provide too much information :slight_smile: but would suggest to try the following:

use your current and default kernel (up to now it’s source, copy the tree in other directory like /usr/src/linux- and configure it with

make cloneconfig
add your driver and compile kernel & modules without specifying any flags (set makeopts to speed up compilation if you want) and don’t forget to change the local version so your running kernel will not be overwritten.

i am not sure why you have to deal with initrd scripts manualy

make install

shoud take care of them

note that suse adds some patches to vanila kernel. use suse kernels’ source to build your own ones.

i guess you configured your kernel in a wrong way so just try without any change.

Actually, I did screwed up original .config :frowning:
How do I get that default .config back?

make cloneconfig executed in kernel source dir will create .config with configuration of running kernel

You should not set CFLAGS on your own when building the kernel.

simply, from whatever reason, compiled kernel worn’t work, on any configuration.
I will be dropping 11.0
maybe a wait for 11.1 or so would be a better choice.
for now, 10.3 would do the job.


…I never give up.

I have installed 10.3, downloaded new kernel, set it up, compiled, then backed up.
Installed 11.0 back on, did make modules_install and make install and it started to function properly. Now I have wireless driver.