how to let Compiz work with "direct rendering"?

I am newbie with Linux.

I get a new ati driver, and installed. Then i start compiz.
but it becomes slow.

>glxinfo | grep “direct rendering”
direct rendering: Yes
driver is ok. but compiz use no direct rendering.

System monitor:
compiz /usr/bin/compiz --ignore-desktop-hints --indiret-rendering ccp

Guys, i wanna know how to enable “direct rendering”?

with the help of Compiz lockup on Intel GMA 950 - openSUSE Forums, compiz runs well now. but still work with “–indirect-rendering”. Why?