How to integrate Authentec Aes2501 Fingerprint Reader?

How to integrate Authentec Aes2501 fingerprint reader into openSUSE 11?

Problem: Fingerprint reader should be used as an alternating authentification during login.

What I did and that works fine:
1st: add software repository Index of /repositories/home:/dgege/openSUSE_Factory
2nd: install software packages: search for fprint and install the software packages “fprint_demo”, “libfprint” and “pam_fprint”
3rd: start the fprint_demo (type fprint_demo into a terminal), scanner works, enroll, verify, identify works fine

Now the problem: The description here doesn’t work
Using Fingerprint Authentication - openSUSE
“Procedure: Registering a Fingerprint”
til point
“On the Plug-Ins tab, select the fingerprint entry and click Launch to open the Fingerprint Configuration dialog.”
I get a error message that fingerprint couldn’t captured immediately (german “Konnte Fingerabdruck nicht erfassen”).

After that I inserted the line

auth sufficient

at file /etc/pam.d/common-auth

Now I have got the same problem like described at the last posting here.

Any hints?

TIA, Ron.


how are this function? do you succeeded recognize the digital finger?

Samuel Rios Carvalho

On Thu, 2008-08-21 at 04:26 +0000, nhawkbr wrote:
> Hello.
> how are this function? do you succeeded recognize the digital finger?
> thanks.
> Samuel Rios Carvalho

My own expericence with this fingerprint scanner is that it is
WAY to sensitive. I did get the fprint test program to recognize
a finger ONCE after storing a pattern, but it took many, many, many,
many, many, many tries (let’s say 50-100 tries).

For this reason, it’s not worthwhile at this time to use that
scanner IMHO.

I’ve got that fingerprint reader, too and the recognization is good, but the technique how you scan the finger is a little bit tricky:

  1. I place my whole hand on the notebook with the index finger on the scanner
  2. Then I slide down and rotate the fingertip a bit more towards the scanner and a bit into the notch.

The YaST Plugin for Fingerprint Readers doesn’t work with the
Authentec AES2501,
i think this is only for the UPEK/SGS Thomson Microelectronics fingerprint reader (USB ID 0483:2016).
I tried the same way as you and failed. :shame:
You have to enroll a finger with fprint_demo and configure PAM.

I just can’t understand why this isn’t working. I’ve inserted the same lines as those described in your link,
because a only want to use fingerprint authentification on KDE login, too.

Maybe you’ve made the same mistake like me. I’ve had installed two drivers the libfprint stuff and the the thinkfinger driver.
Then fprint_demo is able to recognize fingerprints,
but the when you login or do something else where a password is needed there’s no prompt to enroll a finger.

I followed the guidelines here

Opensuse 10.3 on Toshiba Portege R500 « LoBlog

with minor modification. Fingerprint scanner worked first time. (Machine is HP Pavilion dv9572ea with Authentec AES2501).

On openSUSE 11.1 it’s no way easier.
You just have to install the programms
libfprint and fprint_demo (maybe pam_fprint, too)
and than you can do it with YaST.

Unfortunately there’s no infobox, if login
by fingerprint fails, but it works well.

the same problem i want to ask. thanks for others’answers. good post. my friends.