How to install VirtualBox Guest Additions on Windows 7 guest with openSUSE host

I’m having trouble finding/recognizing the Guest Additions from a Leap 15.1 Host to be able to supply them to Windows 7 running in a VirtualBox. claims they are distributed as a .iso with their form of the distribution. Maybe I’ve missed it but I don’t find such in the openSUSE .rpm’s.

Yast2 isn’t showing me any doc rpm’s when I search for virtualbox.

Any help would be greatly appreciated.

I repeatedly wasn’t able to download the iso from the VM.

I finally was able to download it from the Host OS, and utilize it from the VM.

It appears the Guest Additions are installed, however my goal was to use Shared Folders, and somehow those still don’t seem to fully work.

At first, I didn’t think they worked at all.

I set one up from the external Oracle VM VirtualBox Manager tool. Double checked it from the VM menu within the VM. I had indicated I wanted it auto mounted on a particular device letter. Whenever I tried to access it, Windows would say “The system cannot find the path specified.”.

Fortunately, there is a “tooltip” of a type that becomes visible when the cursor is held in place over some of the items while editing the configuration of a shared folder either in the Linux Host based config tool, or the one inside the VM. It describes how the “NET” command can be used from within Windows in the VM to configure access to a shared folder. At least that approach works.

So unless someone knows a way to make the auto mount work, at least I’m happy to have a shared folder working to that extent.

See here: