How to install the Nvidia Drivers

Hi everyone. I am a novice with linux. I need to install the latest drivers for my Nvidia card. I have the Quadro FX 1800.

I don’t think the Nvidia One click installation will work with this card.

I downloaded the drivers from Nvidia and tried to install them but their directions are very confusing. It says “exit x windows” and “restart in init 3”. I don’t know what that means.

Can someone tell me step-by-step how to compile and install the nvidia drivers?

I have opensuse 11.2 64-bit clean install with all the defaults, and the Quadro FX 1800.


With “exit x windows” and “restart in init 3” they most probably mean that you:
Logout of your graphical session (KDE or Gnome or whatever). Then do Ctrl-Alt-F1. You will then change to the system console. There login as root (or as you feel a purist, login with your own userid/passwd and do su -, it asks for the root password. In both cases you will see nothing when you type a password. Then do

init 3

It will bring your system into runlevel 3 where it does not use graphics.
I think from there you can follow your intsructions.

To get back to normal after you installed the driver, an

init 5

could be enough, but a


may be better. Or follow the instructions you have.


Did you try all suggestions on this page? I personally do the repository way since this also enables automatic updating of the driver if you switch kernel. Providing the right modules are actually there :slight_smile:

Nvidia Drivers - OpenSUSE

Always worked fine with my Geforce 8800GT.

You have to exit graphical mode in order to run the nvidia shell script. That’s what they mean by “exiting X”, shutting down the X windowing system and going into text mode.

The ‘init 3’ command shuts down X and takes you to text-only (runlevel 3). Although the “new” way to do this is like this:

rcxdm stop

Then to restart X you would do this:

rcxdm start

After building the nvidia module, you may need to load it manually the first time by using this command:

modprobe nvidia

You may need to have kernel-sources and kernel-desktop-devel (Assuming you’re running kernel-desktop) installed for the kernel version. Check this before you begin by starting Yast > Software Management, and enter kernel in the search box. If they are not installed click the appropriate boxes and click Accept.

Then log out of your desktop and install the driver.

Hi guys thanks for the help.

I added the Nvidia to my repository and that worked.

I didn’t realize you could do that.


There is generally more than one way to get things done and which way to choose is down to the situation and personal preference. Glad it worked out for you!