How to install the driver for ATI Radeon Mobility X1400??

Please refer to below information, that means no driver for my ATI Radeon Mobility X1400, right?

linux-dkkq:/home/baijingjiao/Download # lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
Subsystem: Lenovo ThinkPad T60 [17aa:2015]
00:01.0 PCI bridge [0604]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port [8086:27a1] (rev 03)
Kernel driver in use: pcieport-driver
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
Subsystem: Lenovo ThinkPad T60/R60 series [17aa:2010]
Kernel driver in use: HDA Intel
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 02)
Kernel driver in use: pcieport-driver
00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 [8086:27d2] (rev 02)
Kernel driver in use: pcieport-driver
00:1c.2 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 [8086:27d4] (rev 02)
Kernel driver in use: pcieport-driver
00:1c.3 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 [8086:27d6] (rev 02)
Kernel driver in use: pcieport-driver
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 02)
Subsystem: Lenovo ThinkPad T60/R60 series [17aa:200a]
Kernel driver in use: uhci_hcd
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 02)
Subsystem: Lenovo ThinkPad T60/R60 series [17aa:200a]
Kernel driver in use: uhci_hcd
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 02)
Subsystem: Lenovo ThinkPad T60/R60 series [17aa:200a]
Kernel driver in use: uhci_hcd
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 02)
Subsystem: Lenovo ThinkPad T60/R60 series [17aa:200a]
Kernel driver in use: uhci_hcd
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 02)
Subsystem: Lenovo ThinkPad T60/R60 series [17aa:200b]
Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
Subsystem: Lenovo ThinkPad T60/R60 series [17aa:2009]
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
Subsystem: Lenovo Thinkpad T60 model 2007 [17aa:200e]
Kernel driver in use: ata_piix
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 02)
Subsystem: Lenovo ThinkPad T60/R60 series [17aa:200f]
Kernel driver in use: i801_smbus
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility X1400 [1002:7145]
Subsystem: Lenovo Thinkpad T60 model 2007 [17aa:2006]
02:00.0 Ethernet controller [0200]: Intel Corporation 82573L Gigabit Ethernet Controller [8086:109a]
Subsystem: Lenovo ThinkPad T60 [17aa:2001]
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4227] (rev 02)
Subsystem: Intel Corporation Device [8086:1010]
Kernel driver in use: iwl3945
15:00.0 CardBus bridge [0607]: Texas Instruments PCI1510 PC card Cardbus Controller [104c:ac56]
Subsystem: Lenovo ThinkPad T60/R60 series [17aa:2012]
Kernel driver in use: yenta_cardbus

Then, I downloaded the latest dirver and try to install it:
I tried to follow this guild http://forums.opensuse.org/new-user-how-faq-read-only/advanced-how-faq-read-only/393929-hardware-installing-ati-drivers.html
but I can’t build the package for openSUSE 11.2.

linux-dkkq:/home/baijingjiao/Download # sh ./ati-driver-installer-9-3-x86.x86_64.run --buildpkg SuSE/SUSE111-AMD64

Created directory fglrx-install.XRIE8l
Verifying archive integrity… All good.
Uncompressing ATI Proprietary Linux Driver-8.593…

ATI Technologies Linux Driver Installer/Packager

Generating package: SuSE/SUSE111-AMD64
/tmp/ati.YDpWoS
Package build failed!
Removing temporary directory: fglrx-install.XRIE8l

linux-dkkq:/home/baijingjiao/Download # sh ./ati-driver-installer-9-3-x86.x86_64.run --buildpkg SuSE/SUSE112-AMD64

Created directory fglrx-install.A78Wnp
Verifying archive integrity… All good.
Uncompressing ATI Proprietary Linux Driver-8.593…

ATI Technologies Linux Driver Installer/Packager

Generating package: SuSE/SUSE112-AMD64
Error: Distro Version entered incorrectly or not supported, use --listpkg to identify valid distro versions
Removing temporary directory: fglrx-install.A78Wnp

Have a good read here
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Apologies, but that is for openSUSE-11.1. Why are you using that argument on 11.2 ??

Ok, thats better. You do have a 64-bit openSUSE-11.2, right ?

Ensure that you have kernel-source of the identical version of your kernel installed. Be precise here !! I also typically have kernel-syms of the identical version of my kernel also installed. I also have linux-kernel-headers installed (its version number will not precisely map that of kernel). One also needs gcc, make, …etc and to ensure those are installed I also under YaST > Software > Software Management select the pattern “base development” which will get gcc and make (but not kernel-source, kernel-syms, linux-kernel-headers). You need to pick those up yourself.

If you have any fglrx rpm installed, ensure you remove that BEFORE trying to build the driver.

Also, having typed the above post, I note you have an X1400.

and I re-read this:

I believe that is designated as a legacy hardware by ATI and is no longer supported (ie not in the 10.2 catalyst) and there is a strong possibility that the 9.3 catalyst that you are trying to build from may not work with the 2.6.31 kernel in openSUSE-11.2.

If that is the case, you may be required to use the open source radeon or radeonhd drivers. Information on them is in post#1 and #11 of the link caf4926 provided. In particular note that those two opensource drivers were buggy in the packaged openSUSE-11.2, and one typically has to update those two drivers from the X11 : Xorg repository as described in post#11 of that thread practical theory guide: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

ok, thank you very much!

HCL/ATI Video Cards - openSUSE

Radeon Mobility X1400

Autodetected Image:22px-Tick.png - 3D Support Image:22px-Tick.png Note: As of 11.1, 3D is supported out of the box with the open source drivers, which also supports suspend out of the box (the first version w/ both out of the box on a thinkpad T-60 w/ this card). For openSUSE 10.3 & earlier, 3D and non-VESA resolutions require the proprietary ATi fglrx driver.

That means [Radeon Mobility X1400] should be supported by openSUSE 11.2 automatically right? I needn’t install any driver manully for it, right?

why I can’t enable the desktop effects?

I don’t know. You need to tell us more information so we can make a reasonable assessment. I have no idea as to what you have changed since your first posts.

So please advise, what desktop now? KDE ? Gnome ? LXDE ? XFCE ? Other ? and if KDE, what version?

What graphic driver are you using now? ie what driver according to your /var/log/Xorg.0.conf file? Do NOT post that file here. If you want to show its contents, put it on http://pastebin.be. Does your openSUSE have an /etc/X11/xorg.conf file. Do not post its contents here (if it exists). Put it on http://pastebin.be.

And what is the output NOW of:

rpm -qa '*Mesa*'
rpm -qa '*driver*'
rpm -qa '*kernel*'
uname -a

Since I am not at your PC, I need that to give you a reasonable response.

I tried to set the “Enable desktop effects”, but after some screen flash, the “Enable desktop effects” returned to unselected.

I tried several times the same action, and after logout, then login, I found the desktop effects works.

but when I restart my computer, the “Enable desktop effects” returned to unselected. again, the desktop effects can’t work.

but today, I start my computer, the desktop effects works again, weird.

anyway, it works now.

linux-dkkq:/home/baijingjiao # rpm -qa ‘*Mesa’
Mesa-7.6-3.1.x86_64

linux-dkkq:/home/baijingjiao # rpm -qa ‘driver
xorg-x11-driver-video-7.4-87.91.1.x86_64
xorg-x11-driver-input-7.4-39.2.1.x86_64
xorg-x11-driver-virtualbox-ose-3.0.6-9.11.2.x86_64
cups-drivers-1.3.9-4.1.x86_64
xorg-x11-driver-video-radeonhd-1.3.0_20100216_79a0ab2-0.1.1.x86_64

linux-dkkq:/home/baijingjiao # rpm -qa ‘kernel
kernel-desktop-devel-2.6.31.12-0.2.1.x86_64
kernel-firmware-20090821-4.1.noarch
linux-kernel-headers-2.6.31-3.4.noarch
kernel-desktop-2.6.31.12-0.2.1.x86_64
kernel-source-2.6.31.12-0.2.1.noarch

linux-dkkq:/home/baijingjiao # uname -a
Linux linux-dkkq 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

Glad to read it works.

I’m surprised it works, because you do NOT have the latest Mesa (from x11: xorg) nor the latest drivers (from X11 : xorg) installed.

… are you running with the proprietary fglrx driver?

Did you read here: (post #1 and #11 in that guide): openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

… anyway - if it works, don’t mess with it !!

Just one question… how good your 3D acceration works? Have you tried any 3D accelaration-demanding game with it?

I am trying with games of the Penumbra Collection and the framerate is very slow.

Any comment related to this issue is very welcome

Just an update.
I just upgraded to kernel 2.6.34-x, and to the last xorg packages (Mesa 7.8.1) and the problem was fixed.