How to install Teamviewer 10 in OpenSUSE 13.2

I get an error message saying that my “current backend does not support installing files”

What does this mean, and how do I get it to support installing files?

You can just sudo zypper in /path/to/teamviewer.rpm to install it from any terminal.

Should we guess what you are doing or which program gives you that message when?

Please tell what you do. Not “install”, but exact statement or GUI actions)

Could you please elaborate on this instruction?

I took “/path/to/teamviewer.rpm” to be your shorthand for “/root/tmp/teamviewer_10.0.36281.i686.rpm”

Yast Software Management does not find Teamviewer, and the “install using Apper” from the Teamviewer website yields the message I posted earlier.

Yes sorry, it means the location where the rpm is located and the name of the file.

So let’s say you downloaded teamviewer_cool.rpm to /home/john/Downloads/ the zypper command would be;
sudo zypper in /home/john/Downloads/teamviewer_cool.rpm

Or execute that as root without sudo.

I had this error too on severla occassions. But saving the rpm and installing from dolphin worked, and I think also a second try may have been successful. My guess is, systemd may not provide the necessary service at once. But it’s only a guess.

Regards

Manfred Herteux

I do not see a procedure to edit my post, so I will add another one.

I had assumed that this was a very simple and straightforward question, but obviously it is not.

The Teamviewer website presents options for downloading their software to different OSs. I selected the one for SUSE and downloaded a 37M .rpm file.

I was then presented with an option to open it with “Apper” which I accepted. Perhaps I should have selected the 2nd choice, “Ark” (as an aside, it often seems like the second option presented to me in the GUI is the preferable one).

After seemingly attempting the installation, Apper informed me that my current backend does not support installing.

Then I downloaded the same file into “Downloads” and attempted to install using Ark, with the result that it extracted several new folders into the download folder, but still did not seem to install.

Since I had the file was downloaded, I also attempted to do the zypper from the command line, but that also failed with “specified local path does not exist” and “problem retreiving the specified file” and “malformed URI”

This is what it looks like when I do it;

http://i.imgur.com/muDRJsz.png

You could also try;

sudo zypper in http://downloadeu1.teamviewer.com/download/version_10x/teamviewer_10.0.36281.i686.rpm

In short, it should just “work”.

Thank you! This worked properly.

And I apologize for the extra effort that you expended on my behalf.

I am looking at the 7 packages that were downloaded and trying to understand what happened. Clearly, it was not the simple procedure from the Teamviewer website that I have used for Windows and Ubuntu in the past.

It does make sense that the Yast software manager would not list a commercial program.

Fortunately, I will be able to transition myself into OpenSUSE over time, because there are obviously many techniques and “tricks” that I will need to become comfortable using.

It should work so that you can just click and install the package like you tried to but I’m guessing there’s a bug somewhere that needs to be squashed.

What I suggested isn’t the default procedure if you want to do it the graphical way - it’s just something I’m used to because I find it fast and efficient :slight_smile:

There is a bug in appr it fails the first time try again and it works.

As I learn to understand what happened, I may try to go that route. And, obviously, in the US I will not need to go through the European mirror.

The bit in red is what I will need to learn about, downloading the .rpm was the same everywhere.

sudo zypper in http://**downloadeu1.teamviewer.com/download/version_10x/**teamviewer_10.0.36281.i686.rpm

I will remember that, however, I tried it at least 3 times.

To be honest I only use appr for updates if I’m going to install a rpm form a non repository source I would use the rpm command. type man rpm for all the options.

Note that it’s better to use zypper to install .rpms because it’ll go through all the repositories you have enabled and search for possible dependencies should the .rpm have any - like Teamviewer indeed does.

You could also try;

sudo zypper in http://downloadeu1.teamviewer.com/download/version_10x/teamviewer_10.0.36281.i686.rpm

In short, it should just “work”.

Hi,

You can tell zypper to be more verbose about what it is doing and not keep you in the dark waiting when it is going to finish.

zypper -vv in http://downloadeu1.teamviewer.com/download/version_10x/teamviewer_10.0.36281.i686.rpm

All you have to do is click on the file a second time. Then the dialog box opens and installtion continues normally.

I have found this on many files in 13.2 - it has nothing to do with TeamViewer itself.