How to install OpenSuse from USB or network?


I’ve downloaded OpenSuse 12.1 x64 and I’m trying to install it on my Laptop.

But cdrom drive doesn’t work and now I can’t install it.

I’m trying to install it from USB, but image is 4.3 GB and VFAT only support 4GB files (I’ve downloaded the dvd image).

Is there an easy way to install OpenSuse 12.1 x64 from USB or network?


Did you try suse image writer?
When it was done writing to my usb, windows 7 couldn’t recognise the disk so maybe it didn’t format the disk to something windows can know (and you shouldn’t worry about VFAT too).
you can read more here.
I had to type *.iso to make it (suse image writer) recognise the network install image.

You can’t use the DVD you must use one of the CD iso’s

I have installed from USB, and it seemed easy enough.

Your best bet is to download the live CD image, and write that to the USB using image writer or similar.

The live CD image is already in the correct format for booting from a USB. The DVD image requires a minor tweak (use the isohybrid command, which you might have to first install). If you have not done it before, going with the live CD image (iso file) will be the best way to start.

Limitations on VFAT don’t actually matter. Installing the iso on a USB overwrites the original formatting anyway.

As tetsu suggested, install imagewriter and write the DVD iso to your usb stick. Unless something changed with the 12.1 dvd, the usb should be bootable without further tweaks.

Thanks for the reply, but go on with problems.
What I’ve done:

  • Formatted a 16GB USB with ext3.
  • Copied DVD image in a directory called /root int the usb.
  • Executed isohybrid openSUSE-12.1-DVD-x86_64.iso from the /root directory in the usb.
  • Restarted computer.
  • Try to install from usb, but doen’t work.
    Any suggestion?

What I’ve also done:

  • Move image from /root to /.
  • Executed isohybrid openSUSE-12.1-DVD-x86_64.iso
  • Put partition of USB as active.
    Now it says that is unable to start from USB doe to there is not a Operating System.

Finally has worked.

  • I executed isohybrid openSUSE-12.1-DVD-x86_64.iso in a copy in the hdd.
  • Executed dd_rescue openSUSE-12.1-DVD-x86_64.iso /dev/sdb (is my usb unit)

Now it has worked.


Yes, that’s what has been working for me, and is what I understood the instructions to be saying.

I only use an 8G USB drive - there was no point in buying more than I needed.

I’m glad you have it working. And thanks for posting the steps that work. It might help others.