How to install network adapter on 12.3?

Hi everyone,

I got a new pc that is dell optiplex 7010. After I installed openSUSE 12.3 using DVD, the OS can not find the network adapter which is Intel 825xx Ethernet Controller. I try to download e1000e-2.3.2.tar.gz from, but it can not be compiled. Is there any suggestion for me? Any help will be appreciated.

BTW, I use GNOME. The Ethernet controller is Intel Corporation 82579LM Gigabit. Thanks.

If you need Intel-e1000e you should check out this page -

After I ran intel-e1000e.ymp, it tried to access Index of /repositories/home:/ghaskins/openSUSE_12.3. However, my adapter does not work. So what can I do the next? Thank you very much.

Don’t download the 1-click install file.

Download the packages themselves and install them using “sudo rpm -i rpm_filename1 rpm_filename2”.

Which ones you need exactly, depends on what kernel you are using.
Please show the output of “uname -a” if you need more detailed instructions on what to download.

Thank you. After I ran the rpm, it shows:

>sudo rpm -i intel-e1000e-2.3.2-3.1.x86_64.rpm
warning: intel-e1000e-2.3.2-3.1.x86_64.rpm: Header V3 DSA/SHA1 signature, key ID abde7ce2: NOKEY
>uname -a
Linux 3.7.10-1.1-desktop #1 SMP PREEMPT Thu Feb 28 15:06:29 UTC 2013 (82d3f21) X86_64 X86_64 X86_64 GNU_Linux

if I ran intel-e1000e-2.3.2-5.1.x86_64.rpm, the result is same.

That’s just a warning, the rpm should have been installed fine.
But which one do you have installed now?

rpm -q intel-e1000e

You also need the kernel module: intel-e1000e-kmp-desktop-2.3.2_k3.7.10_1.1-5.1.x86_64.rpm if you have intel-e1000e-2.3.2-5.1.x86_64 installed, intel-e1000e-kmp-desktop-2.3.2_k3.7.10_1.1-3.1.x86_64.rpm for the other one.

Both of them.
>rpm -q intel-e1000e

I use GNOME. How to setup these kernel module you said?

Then remove both of them:

sudo rpm -e --allmatches intel-e1000e

And install **one of them **again.

I use GNOME. How to setup these kernel module you said?

Just download the right one and install it with “sudo rpm -i intel-e1000e-kmp-desktop-2.3.2_k3.7.10_1.1-5.1.x86_64.rpm” f.e.

I am sorry to reply late. I do not find where these files can be downloaded even I clicked the link you gave. Would you like to give me downloading link directly? I appreciate it.

Oops, sorry! I pasted the wrong links…:shame:

Install those two packages:

So stupid. I find and setup them, but I still can not find adapter in the network connection.

I have no idea why the system could not find it. When I click System Setting -> Network, it always shows “The system network services are not compatible with this version”. What can I do the next? :’(

That’s a different problem. There seems to be something wrong with your NetworkManager installation.
But you don’t need that.

Did you reboot your computer after installing the network driver?

Please check in YaST->Network Devices->Network Settings if your card is listed. And make sure “Traditional Mode with ifup” is selected on the “Global Options” tab.

Dear wolfi323](,

The card is working now. I really appreciate it. When I opened Network Settings, the system gave this card a static ip address by default. After I changed it like you said, it works very well. Thank you so much.
Have a good day.