How to install logitechmediaserver

Hello there,
I try to install logitech media server from home:rikj:logitechmediaserver repo.
When I run the install I get

sudo zypper install logitechmediaserver
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: 1: nothing provides 'perl-EV' needed by the to be installed logitechmediaserver-7.9.2_final-lp155.27.1.noarch
 Solution 1: do not install logitechmediaserver-7.9.2_final-lp155.27.1.noarch
 Solution 2: break logitechmediaserver-7.9.2_final-lp155.27.1.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c): c

Then I want to find perl-EV’

sudo zypper wp perl-EV
Command 'what-provides' is replaced by 'search --provides --match-exact'.
See 'help search' for all available options.
Loading repository data...
Reading installed packages...
No matching items found.

sudo zypper se perl-EV
Loading repository data...
Reading installed packages...

S | Name                  | Summary                                                          | Type
--+-----------------------+------------------------------------------------------------------+-----------
  | perl-Eval-Closure     | Safely and Cleanly Create Closures Via String Eval               | package
  | perl-Eval-LineNumbers | Add line numbers to heredoc blocks that contain perl source code | package
  | perl-Event            | Event loop processing                                            | package
  | perl-Event-ExecFlow   | High level API for event-based execution flow control            | package
  | perl-Event-ExecFlow   | High level API for event-based execution flow control            | srcpackage
  | perl-Event-RPC        | Event based transparent Client/Server RPC framework              | package
  | perl-Event-RPC        | Event based transparent Client/Server RPC framework              | srcpackage

What should I install?
Thanks

I would write a commend to the Maintainer on the OBS…

Requires: perl-EV

I think since ‘perl-EV’ is not found, you might need to manually download and install it from another source. And you can search for similar packages that might fulfill the dependency, such as ‘perl-Event’, and install them to see if they resolve the issue.

bor@bor-Latitude-E5450:~$ osc se perl-EV
No matches found for 'perl-EV' in projects
####################################################################
matches for 'perl-EV' in packages:

# Project                        # Package
devel:languages:perl             perl-EV
devel:languages:perl:CPAN-E      perl-EV
devel:languages:perl:autoupdate  perl-EV
home:aginies                     perl-EV
home:beyerle:IAC                 perl-EV
home:bjoern_beutel:Aareon-Perl   perl-EV
home:csbuild:Perl                perl-EV
home:dirkmueller:AL:EPEL9        perl-EV
home:mnhauke:squeezebox          perl-EV
home:rikj                        perl-EV
isv:perlur:epel                  perl-EV
bor@bor-Latitude-E5450:~$ 

Thank you all.
In devel:languages:perl/15.5/x86_64 I found 3 missings packages;
perl-EV-4.33-lp155.1.2.x86_64.rpm
perl-IO-AIO-4.810.0-lp155.2.1.x86_64.rpm
perl-Image-Scale-0.14-lp155.1.3.x86_64.rpm
I installed them with zypper and succeeded to install logitechmediaserver
Just to see this is not the last version :unamused:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.