How to install compiz screensaver?

Hi, maybe anyone knows how to install compiz screensaver, which has the possibility of showing the cube and flying windows, on suse 11.1. Thanks for help

try the git plugins pretty sure it should be in there but it is experimental.

Holy **** (I didn’t even swear, I just typed “****” so anyone could use their imagination on which profanity I used) If I could give you a million rep points for that information I would. The flying windows as a screensaver is AMAZING. Thank you very much for that link!



I just tried to turn Suse into the distro I like I use just compiz-fusion as my desktop with cairo-dock and compiz-deskmenu.

Had to give up with Suse wants to pull in half of gnome or KDE and I want neither.

If you want we can get get cleverer still go get xwinwrap and then have electricsheep running in the cube, but boy does that eat some cpu cycles.

thanks FeatherMonkey, but unfortunately the one-click install doesn’t work (reports only partial successfull install) in my case,I’ll try to install rpm manualy to solve the dependency problems, but thanks for the tip anyway.

I haven’t tried that myself yet, but I have 10.3 so I’m going to try it for 10.3, but it says that in order to use it that you have to have Compiz-Git, so I’m wondering, in your case, whether you have Compiz-Git installed or not, and maybe, if not, maybe to get the 1-click to work, maybe you need to do a 1-click install on Compiz-Git first, then on the plugins maybe ?

I’m going to try it myself, but for me it will be for version 10.3 until I can buy more CDs or DVDS so I can burn an ISO image of 11.1, as I’m all out of blank ones…I always bought the cheaper CD/DVD-R ones instead of the higher-priced CD/DVD-RW ones so I can only burn them one time, but maybe I should have a few where I can erase and re-burn them with new ISO images.

These packages must be installed from that repository for it to work:

compiz-git-kde (or gnome whichever DE you’re using)

Also it relies on the kde3.5 base so there are a few extra that it installs itself. But those packages above are must haves for compiz to work.

If you’ve tried it already it’s subscribed to the repository so just open Yast Software Management and filter by repository. Choose home:pedro_seon and then install those packages above from that repository. Otherwise you’ll need compiz-git first from here

One last thing, the screensaver with flying windows does not work properly when the 3D windows plugin is enabled. The rotating cube screensaver does work with 3D windows plugin enabled.

Good Luck,


I took the liberty of taking a video of these effects in action. Note: My graphics card is far from superior and my cpu is also not the best. SO it’s a bit choppy.

I first show the Flying Windows Screensaver. Then I show the Rotating Cube Screensaver. I then show rotating cube with 3D Windows Plugin enabled. I then show Flying Windows with 3D Windows Plugin enabled to show the glitch. I then disable 3D windows and show Flying Windows again to show that it’s the culprit.

Total time is 1:46 seconds. It’s a 34.2MB Download

Take Care,


Thanks guys, I’ll try it when I get home

I feel the need to post this, you are using a git repository. Someone is kindly providing rpm’s for it.

What does git mean? It means development.

I do not know how often those packages are being updated or what part they are from.(Sorry no I don’t use it)

The problem with using things like git is without following mailing list, bug reports you may one day find you download it and the src tree is broke. It may be fixed in the next half an hr, it may be several days, it may have a severe bug, it may have no bugs, it may have minor bugs.

So you’re on your own, there is no point posting compiz doesn’t work if you’re using git. Investigate find out when it was snapped and post a bug report upstream, learn how to use gdb, how to get to logs, make sure you have alt sysRq enabled and know what to do etc…

Oh, I didn’t know you were posting that to me.

Yeah I wasn’t trying to get help or anything; I realize it’s not a stable repository, as every description it gives says everything is experimental. I was posting it to show it’s possible to use and how awesome it is once you get it working. And also posting the glitch so if it’s not fixed yet and someone else ends up with the glitch, they’ll know the culprit of it.

Thanks for the warnings though, I’ll keep them in mind if something completely horrible goes wrong :wink:

Take Care,


Wasn’t directed at anyone in particular just a general warning :wink:

From the sounds of things you understand the limits of your CPU. It’s just I can see a few people go wow I want that without being aware of the consequences.