How to install ATI Graphic drivers

Hello, could anyone help me on how to install my graphics card drivers ATI Radeon X800. The easiest way is the best way, because I’m a noob, and new to all of this.

All help much apreciated thanks. I tried looking at the help this site has on it, but It hasn’t worked.

Sure! Can you start by telling us what openSUSE version you are using?

You may also take a read here:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

… my guess is your solution is to apply the vesa driver (per the guidance in post#1 of the quoted thread) to get started with a GUI. Then apply the guidance in step #11 of the quoted thread above to update the radeon and radeonhd drivers for your ATI x800. Then apply the guidance from step#1 in the quoted thread above to apply the updated drivers.

Thank you for the reply, I’m using 11.2

OK, do you have X window (KDE or Gnome) running now with any sort of graphic driver ? If so, can you tell us what driver?

I have GNOME. I’m not sure if I have it running with a driver, and If I do, then I’m not sure which. Is there a way I can find out?

Thank you.

There is by looking at the /var/log/Xorg.0.log file (which is a bit of a pain). If you type:

gedit /var/log/Xorg.0.log

and then look for occurences of
(==) VESA(0): and
() VESA(0):
then you are using the vesa driver
(==) RADEON(0): and
) RADEON(0):
then you are using the radeon driver.

Hmm, I looked but I can see both… like you said bit of a pain to look at. What shall I do now?

OK, then I assume you have Gnome running in a desktop with some graphic driver, and you want to improve the driver.

First, my understanding is the X800 is a legacy hardware according to ATI and they do NOT support this hardware any more.

Hence you have to use the openSource driver. The openSource radeon and radeonhd driver that came packaged with openSUSE-11.2 were buggy, so I have recommended users who want to use the radeon and/or radeonhd drivers update to the more cutting edge version of that driver which is on the X11 : xorg repository.

Guidance for that is in post#11 openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums … and to do that simply add the repository by typing in a terminal or konsole (hopefully you know how to do that) “su” (no quotes - enter root/admin password) followed by:

zypper ar newrepository

that will add the repository. Then go to YaST > Software > Software Management and add the “newrepository” versions of Mesa, xorg-x11-driver-input, xorg-x11-driver-video, and xorg-x11-driver-video-radeonhd. Ensure you update and do not believe YaST if it says they are already installed. Note in YaST you MUST pay attention to the version tab. See this sketch to give you an idea.](
… Now once those are updated, remove the repository you added, with:

zypper rr newrepository

note “newrepository” is an arbitrary name I made up. Put in bill, bob, george, sunshine, lazy, funny, any-name-you-want there.

Then reboot your PC, and before we do any more, I need to find out what driver you are using, and whether your PC has an /etc/X11/xorg.conf file.

I think what you’re looking for is the ATI Catalyst driver. You can download them from here:

Graphics Drivers & Software

Select linux_x86 (or linux_x86_64 if you’re 64-bit)

Select Radeon, ‘ATI Radeon X8xx Series’

Then download the “ATI Catalyst™ 9.3 Proprietary Linux x86 Display Driver”.

To actually install, you’ll have to give the “.run” file execute permissions.

Drop to a terminal and type:

> chmod +x

then execute the installer by typing:

> ./

(obviously, type the actual name of the .run file)


Open the file with a text editor again:

gedit /var/log/Xorg.0.log

copy it and then paste it on this web site: and press dump on that web site. It will give you a URL. Post that URL here. Just the URL. Do NOT post the file contents here (its too big).

I confess its not clear to me if the X800 is supported by the catalyst ?

According to this on the ATI/Amd site:
ATI Catalystâ„¢ Proprietary Display Driver

AMD has moved a number of DX9 ATI Radeon™ graphics accelerators products to a legacy driver support structure. This change impacts Windows XP, Windows Vista, and Linux distributions. AMD has moved to a legacy software support structure for these graphics accelerator products in an effort to better focus development resources on future products.

The following products have been moved to the legacy software support structure (including Mobile and All-in-Wonder Variants):

ATI Radeon 9500 Series
ATI Radeon 9550 Series
ATI Radeon 9600 Series
ATI Radeon 9700 Series
ATI Radeon 9800 Series
ATI Radeon X300 Series
ATI Radeon X550 Series
ATI Radeon X600 Series
ATI Radeon X700 Series
ATI Radeon X800 Series
ATI Radeon X850 Series
ATI Radeon X1050 Series
ATI Radeon X1300 Series
ATI Radeon X1550 Series
ATI Radeon X1600 Series
ATI Radeon X1650 Series
ATI Radeon X1800 Series
ATI Radeon X1900 Series
ATI Radeon Xpress Series
ATI Radeon X1200 Series
ATI Radeon X1250 Series
ATI Radeon X2100 Series

AMD may periodically provide Windows XP and Windows Vista driver updates (for the products listed above) for critical fixes only. No new features will be provided in future driver updates. The Linux ATI Catalyst™ driver will only be supported in Linux distributions prior to February 2009 for the legacy products listed above.

Any customers using a combination of a ATI Radeon™ HD 2000 Series, ATI Radeon™ HD 3000 Series, or ATI Radeon™ HD 4000 Series product with any of the legacy products listed above in a single PC system must use the ATI Catalyst 9.3 or earlier driver. All future ATI Catalyst™ releases made available past the ATI Catalyst™ 9.3 release will not include support for the legacy products listed above or any of the features associated with those legacy products
.ie the Catalyst driver does NOT support the X800. … Or did I misread the above?

… I had thought that the 9.3 Catalyst was NOT compatible with the 2.6.31 kernel that is in openSUSE-11.2.

That is one of the reasons why I asked at the start, what openSUSE version the user was using.

I’m on 2.6.31 and running catalyst 9.3 just fine (granted it’s a different graphics chipset)

BTW, ATI “not supporting” a chipset in the driver, and it “not working” are two different things.

In the OP’s case, I think it would be worth it to at least give the catalyst drivers a shot.

Is this an X800 you have working? IF not , then this is NOT applicable.

I am concerned you are providing inaccurate advise. Please, can you be specific as to whether you have this running on an X800? My experience in reading my graphic support threads on this forum is many X800 users had problems with the catalyst driver.

Sample threads of users with problems

Unless I read a simple X800 how to for the Catalyst 9.3 with openSUSE-11.1’s 2.6.31 kernel, then I stand by my recommendation to update the radeon and radeonhd. Please note the users 1st post! They are not an average nor an advanced user.

I’m gettign a bit muddled with this.

‘Then go to YaST > Software > Software Management and add the “newrepository” versions of Mesa, xorg-x11-driver-input, xorg-x11-driver-video, and xorg-x11-driver-video-radeonhd’

So I click on the newrepository, and then what?

Have you installed those rpms ? After you select the new versions to install, you click on “accept” and they install.

This is what I HATE ABOUT GUIs. It takes forever to explain them, and users still do not understand.

Anyway, after you have them installed, REMOVE that repository like I advised. Then reboot.

Have you installed those rpms ? After you select the new versions to install, you click on “accept” and they install.

What new versions?

Sorry about this.

The new versions of the applications I advised you to update. Please read this quote:

Please advise if that is not clear now.

This is what happens whilst I try to install them.

Error: IO:Failed to provide Package xorg-x11-driver-input-debugsource-7.4-108.4. Do you want to retry retrieval?

[X11:XOrg|] Can’t provide file ‘./x86_64/xorg-x11-driver-input-debugsource-7.4-108.4.x86_64.rpm’ from repository ‘X11:XOrg’

  • Can’t create /var/cache/zypp/packages/X11:XOrg/x86_64
  • Can’t provide ./x86_64/xorg-x11-driver-input-debugsource-7.4-108.4.x86_64.rpm : Can’t create /var/cache/zypp/packages/X11:XOrg/x86_64

I expect I’m doing something wrong…