How to install a Canon wireless printer-scanner like the "i-Sensys MF744Cdw"

This is for SUSE noobs like me. Advanced users can probably ignore this. But I’m hoping I can save future noobs some time when they need to set up their Canon wireless printer-scanner.

Coming from Debian and loving OpenSUSE Tumbleweed, I was a little disappointed when I tried to set up my Canon MF744Cdw printer-scanner. On Debian, everything worked instantly without me installing anything. On SUSE, I had to search the web far and wide and tinker around a bit. So here it is, short and sweet.

To get the printer going:

  1. I could not get driverless printing to work.
  2. So I had to download the Canon drivers from their website (I read somewhere they are not available in all countries, but I can confirm the English drivers on www.canon.de work well.) The UFR-II drivers make things complicated (unless you’re on Fedora, there they work flawlessly). The CQue RPM English drivers are straight-forward. Download these.
  3. Install the .rpm file either by double clicking it or using sudo rpm -i cque-<filename>.rpm to get some feedback (if you don’t get error messages, things are probably fine).
  4. You can use YaST > Hardware > Printer if you like - but I prefer the CUPS web interface at http://localhost:631. Go to Administration > Find New Printers > choose the one with an ipps://... connection. To find out which discovered printer is the right one (if more than one are discovered): click on whichever discovered printer and check the protocol that it uses - if it’s a different one, go back and try the next one. Click next and choose Canon > MF744Cdw (or whichever printer applies to you). Confirm and you’re hopefully golden.
  5. Adjust any printer settings you like in the CUPS web interface.

To get the scanner going is very easy, once you know how:

  1. Install sane-airscan, e.g.: sudo zypper install sane-airscan
  2. Use any scanning software you like (e.g. the pre-installed “Document Scanner”) and the scanner should be recognised as “eSCL Canon MF742C/744C [long string of numbers]”.
  3. Scan away.

Good luck everyone!

In addition to that, many new users forget about active firewalls when discovering network printers and scanners. Make sure that “mdns” (Avahi discovery) and “ipp-client” (for IPP printers) is allowed in the applicable zone for the LAN interface.

Oh man yes! Can’t believe I forgot to mention that. It was of course the first issue I ran into. Thanks for mentioning it. This is one of the moments I find it a shame I cannot edit my above post to add that info.

If running into problems, I find it a good temporary measure to turn off the firewall completely until printing and scanning works, and turn it back on afterwards.

Since my computer is connected to my trusted home wifi, it was enough to change the zone of my wifi connection to “home”. The easiest GUI way to do it was to install “firewall-config” (sudo zypper install firewall-config) and then go to Options > Change Zones of Connections… > choose the wifi connection > change it to “home”. I’m sure it’s just two or three commands in terminal, but I had it installed already anyway, so this was quicker.

Interestingly, I just checked my settings and while “mdns” is allowed, “ipp-client” is not. But printing works. Should I enable it anyway?

Neither is needed for printing as such, but CUPS can use these for discovery purposes.

1 Like