how to have yast in english

on my fresh installed leap 42.2 with standard plasma plasmashell 5.8.3
I set languages for the users modifying the .profile file adding export LANG=en_US.UTF-8 or export LANG=it_IT.UTF-8 or other
I copied in the /root folder the same .profile file, when I access as root everything is in english, but when I access to yast from another user the yast language risult italian and also some popup appear in russian (I rebootet many times)
http://paste.opensuse.org/view/download/96243184
or mixed english italian
how can I have root and yast and other in the english language??
and also how can I have the correct language of the user??

What did you use as the system language on installation?

BTW, I think it is not a “best practice” to do system management tasks starting from all sorts of users. Of course when those users are used by different human people, that is normally the case, because those human people will not know the root password. But IMHO even if you as one human use more users (which can be a very good idea), I think you should use only one of those users (or one special created for that) as a starting point to do system management tasks.
After all, how often do you need YaST in daily life? Once a week or so?

Oh, and you can always start YaST from a root terminal and precede it (like every command) with LANG=C

LANG=C yast2

may be italian…

the use cases are all, the users that use yast speaks one italian and one english and one russian, but it is very annoying to describe or follow instructions in english on an italian yast:)

this works manythanks…

…but why the comments and the dolphin line of dolphin in superuser mode is in russian??? :slight_smile:

There are two man language settings one for system files (ie root) and another for each users usually set in the desktop. Maybe the system setting was set originally or changed to Russian by the Russia speaker root user

You can add LANG=C to the command in the menu so that for you you get english for yast