How to have knetwork manager launched every KDE boot ?

I’ve just setup my mother’s desktop PC (HP P6510F) which has a wired connection to the internet, with 64-bit openSUSE-11.3 KDE-4.4.4 desktop. Her PC also has a wireless device, so I decided to set that up. I have it working with the internet (using knetworkmanager), but I have to launch knetworkmanager from a terminal each boot, as it is not launched every boot by default.

What is the ‘proper’ way to have knetworkmanager launched every boot in KDE4 ? (I can hack at this, but if there is a preferred/recommended method, I would rather use that).

I suspect no more detail is needed, but in case one is curious:

Her wireless is:

02:00.0 Network controller [0280]: RaLink RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]
        Subsystem: Lite-On Communications Inc Device [11ad:6632]
        Kernel driver in use: rt2860

and her driver is:

mothercpu@mothercpu-HP:~> lsmod | grep rt
rt2860sta             578083  1 
crc_ccitt               1707  1 rt2860sta

where I obtained the driver from the repository:

installing the rpm: rt2860-

… and for the record her wired is:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
        Subsystem: Hewlett-Packard Company Device [103c:2a92]
        Kernel driver in use: r8169

The idea is her PC will use wireless most of the time, but wireless is available for her in case she wishes to move her desktop PC to a location where it is not convenient to run a wire.

Again, wireless works fine ! I just want knetworkmanager launched automatically every boot.

But are you set up in the Yast as ifup or networkmanager?

My Laptops spend most of their life hooked up to the wire (they do not run as ifup but rather networkmanager)
I just connect/disconnect the wire as and when and it all happens like magic.
If networkmanager is running at shutdown, it should start again at reboot.

Do you actually mean “every boot” or “when KDE4 starts”?

cp /usr/share/applications/kde4/knetworkmanager.desktop ~/.kde4/Autostart/

…should do that. The KDE4-systemsettings also offer a module for autostarting.

Setup in YaST as “user controlled with networkmanger”.

I really just want it done the ‘nominal’ way this is done. I assume knetworkmanager is launched with KDE4 is started. It would not make sence to me to have it launched before (but I confess I am not knowledgeable in this). I know of the KDE4 autostart method, but I’ve never had to do that with my 2 laptops, so it surprises me a bit I need to do that here. … I’ll have to go check my laptops to see how they are setup (mind you they have different hardware).

Every install I ever do, it’s just there, but I’m talking Laptop
The Desktop, No - But I don’t have wireless there at all.

I really just want it done the ‘nominal’ way this is done.

The KDE-autostart is as nominal as you can get - what’s the problem with it?

However, there seems to be a second way of autostarting in KDE4, because my ~/.kde4/Autostart/ is empty, yet Yakuake starts as soon as I log into KDE. As mentioned, there’s a module in the KDE4-systemsettings to manage autostarts (where I can find an entry for Yakuake), you should give it a peek.

I put a shortcut to knetworkmanager on the desktop. Simply clicking on the icon starts the nm. While it is not an autostart it is fast and easy to use

Hi oldcpu,

Knetwork manager is not a good manager, try wicd instead : Résultats de recherche

Nothing wrong with it, … but clearly there is another way that is nominally used, and I wanted to learn how to do it that way.

It appears this ‘nominal way’ (without using the KDE4 autostart) is not ‘common’ knowledge

… I ended up putting knetworkmanager in my mothers ~/.kde4/Autostart/ and it works well, but I am none the wiser as to the ‘nominal’ method.

Well, good that it works.

I don’t quite understand your point, though. The /Autostart-folder has always been part of KDE an it does exactly what you wanted to do.

Lee, take a look in the systray settings. Activate networking in there. The networkmanager is starting, you just don’t see it. My 2 cents