how to go back to windows

i been using opensuse for about 2 weeks
what a amazing experience
but i just cant find some software that i usually use on windows
and i also had a license for windows

is there a way to boot it back to windows? or maybe dual boot it
i havent format my windows partition
when i boot my laptop up, it only shows opensuse option

i tried to burn windows7 iso using imagewriter and unetbootin but both doesnt work (imagewriter didnt support it maybe)
but when i burn other distros like linux mint, it work

on the bios menu, it shows an option for grub2win,but it cant boot to that (it boot to opensuse again)

sorry if my question was dumb


You give too little information.

I’ll guess. Maybe openSUSE is using UEFI booting while Windows 7 is using MBR booting. If that happens to be the problem, then you need to get into BIOS settings on how you boot.

im using windows 10

That doesn’t change much.

Normally, the grub menu you use for booting openSUSE should have an entry to boot Windows. However, if one of your systems is using UEFI booting while the other is using MBR booting, then you won’t have that menu entry. That’s because those ways of booting are not compatible.

This is still the most likely explanation for your problem.

Can you post the output from

parted -l

Run that as root, and use CODE tags to post the output.

If windows is still installed on the computer, you have two possibilities:

  1. You go to your BIOS and change the boot order
  2. In Linux, in a terminal you type efibootmgr. It should give you the list of OS / medias with which you can boot your computer. When you have this, you can type efibootmgr -n and the number of the OS/media you want to start.

Hereunder an example from my laptop: (run as root)

gwerlas:~ # efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,2001,2002,2003,0002,0000
Boot0000* opensuse-secureboot
Boot0001* openSUSE
Boot0002* opensuse
Boot2001* EFI USB Device
Boot2003* EFI Network
gwerlas:~ # 

Now if you want to boot your pc with, let’s say, a usb device, you just have to type efibootmgr -n 2001 and then reboot.

 Model: NVMe Device (nvme)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                  Flags
 5      1049kB  290MB  289MB   fat32                                 boot, esp
 3      290MB   116GB  115GB   ntfs            Basic data partition  legacy_boot, msftdata
 1      116GB   116GB  8389kB                                        bios_grub
 2      116GB   118GB  2147MB  linux-swap(v1)                        swap
 6      118GB   150GB  32.3GB  ext4
 4      150GB   210GB  59.8GB  ntfs            Basic data partition  msftdata
 7      210GB   256GB  46.1GB  btrfs

heres mine

erik@localhost:~> sudo efibootmgr
[sudo] password for root: 
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0007,000F,0000,0010
Boot0000* Phoenix OS
Boot0001* Prime OS Loader
Boot0002* opensuse
Boot0007* Grub2Win EFI - 64 Bit
Boot0008  Setup
Boot0009  Boot Menu
Boot000A  Diagnostic Splash
Boot000F* NVMe: WDC PC SN530 SDBPMPZ-256G-1101         
Boot0010* USB HDD: SanDisk Cruzer Blade

it just doesnt boot, and after i reboot, the priority change to opensuse again
and those phoenix os and prime os, how to delete them? i removed its file but it doesnt go away
i tried to burn windows 7 iso and boot to usbhdd, but it boot back to gnu grub

If you want to change “definitively” the boot order, you have (again) two possibilities:

  • go to your bios configuration and adapt the boot order
  • use “efibootmgr -o” and give the boot order you wish to have, for example: efibootmgr -o 7,2,10

efibootmgr -n change the boot order only for the next boot, you can find more info by typing ‘man efibootmgr’ in a terminal

If you have a usb stick with a windows iso, you can also change the boot order in your BIOS by setting your usb stick at the first place. The usb must well be plugged in before you go into the BIOS

To burn a windows iso, install first in opensuse the imagewrite package (sudo zypper in imagewriter), then donwload the image and then start imagewriter. This app is quiet intuitive, so you shouldn’t have any problem with it.
Once it has written the iso to the usb, plug this one out and in, so you can see if the iso was written into it and then adapt the boot order via efibootmgr (or via your BIOS)

Note for Linux to see Windows partitions you MUST turn off fast boot in Windows. It leaves Windows partitions in a unclosed state which Linux can not deal.:open_mouth:

It’s been a half-year or so, but I think I had to use WoeUSB rather than Imagewriter to successfully burn Win10 installation media to a USB stick. I was able to dump the Win install shortly afterward and haven’t looked back, so my memory might be playing tricks on me … but, that’s what I remember. Imagewriter has been great for everything except Windows.

how can i know whether its turned on or off? or can i change it?

Strange, about 18 months ago, I burned a win10-iso-image with imagewriter and all went OK.
But, nevermind, woeusb is also available for Leap 15.3 and Tumbleweed.

Look in the registry


0 = disabled
1 = enabled



I would like to advice you to go for a dual boot.

To see if windows is still installed, one thing to try is, if it will boot.

Depending on your bios, you probably can hit an Fkey to bring up the boot menu. Select windows there and it should boot.

If you install opensuse the default suggestion is to go dual boot, it wont delete windows unless you tell opensuse to do so.

If windows is still installed, but does not show in the grub screen. Go into yast bootloader and check probe foriegn os.

This last part will only work if both os use mbr or both use eufi secureboot. As stated already in this topic you can’t mix them.

I believe it is on as default. Can be turned off somewhere in Windows.


So and



  1. or