How to get Totem to play everything, and show thumbnails

I followed the guide for restricted formats and i can play my videos with SMplayer, Xine, VLC etc but not Totem. Totem in 11.3 uses Gstreamer, and i believe i have all gstreamer plugins installed, good, bad, ugly, base etc. Also thumbnails won’t show. Reason i want to use Totem? cuz it’s integrated well with Gnome

THere’s also this issue where everything i try to play wants to be played with banshee, how do i stop that? i tried going into Preferred applications and put it on custom, but i can’t differentiate music and video, there’s just a multimedia option.
I would like to have music autplayed with Banshee, and Video autoplayed with SMplayer without having to go through the right click, play with option :confused:

Full screen flash is aproblem in 11.3 64 bit just as it ALWAYS is in most distros i tried sigh there’s stuttering, and i can’t scroll through the video ideally.

For the sake of saving spack i have a non multimedia related question. How do i handle nzbs? in windows i use sabnzb which is cross platform, but their is only a Fedora RPM meaning i’ll have to compile it for opensuse which i have NO Idea how to do. Alternative NZB handlers i can’t find in the regular repositories or webpin. Note ven teh popular hellanzb or lottanzbs :frowning:
Thanks for the help

Totem Sucks…there I said it

Right click a media file Eg: a .avi
Properties > Opens with Tab
Select the application

I need to be able play the files with Totem first. I’m missing sound codecs, cuz i get video with a lot of my files. Why does totem suck btw? i would agree but it allows nautilus integration which i like.

Let me see your repos

zypper lr -d


enable packman and search for gstreamer.

Add the fluendo plugins from packman as well as all the other gsteamer plugins.
While you are there, install the win32all codecs.
Make sure you change the default suse version to the packman version of gstreamer.

I have found it is fine on 11.3 for everything except some .wmv files.

here’s a one stop manual for playing restricted formats:
Restricted Formats/11.3 - openSUSE Community Wiki


| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
2 | | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.3/ |
3 | openSUSE-11.3 11.3-1.82 | openSUSE-11.3 11.3-1.82 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
4 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/Factory:/Contrib/openSUSE_11.3 |
5 | | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /suse/11.3/ |
6 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
7 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
8 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
9 | repo-source | openSUSE-11.3-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.3/repo/oss

I didn’t have teh fluendo mpegdemux codecs it seems. I installed it but still no sound, but i get the thumbnails though.

CHeck original post. I did the guide already

Remove repo 2

Then do this:
ImageBam - Fast, Free Image Hosting and Photo Sharing

You didn’t follow my guide did you
Multi-media and Restricted Format Installation Guide

I did follow the guide exactly as you said, i didn’t want to use the QT software manager, i preferred the Gnome version. Still trying to learn KDE.

Haven’t done it yet, but it raises questions. Why must repo 2 be removed? How does it affect the outcome?
The picture you posted, Can you explain in detail what that switch to packman repository does exactly?

I’m going to switch to KDE SUSE, cuz it seems KDE is going to be the future haha and I’m understanding it a bit. How do you change the tooltip fonts in KDE??

You need to add the Packman repo.
Go to yast2>software>s/ware management.
Now choose ‘Repositories’ and click edit. This brings up the choices for adding a repo.
Choose community repos and then packman.

All you need from the vlc repo is libdvdcss. Install this first and then edit the repos again and disable the repo.
Now add the gstreamer plugins from packman.

Packman is already in the list

I did follow the guide exactly as you said,
No you didn’t - otherwise I wouldn’t be telling you to remove repo 2.

The switch makes sure all multi-media packages are from Packman, this is very important.

oops i meant i did NOT follow the guide exactly as you said lol
I didn’t see why having a repo present would’ve changed anything so i ignored that. I assumed i’d probably want to get new VLC updates in the future, so i left it :confused:

Hmm, about the switch, then shouldn’t packman’s repo be present on default install then since teh codecs there are ‘superior’? to the ones in the other repository. I don’t get it :frowning: sorry if i’m being mischievous

openSUSE cannot supply the codecs for legal reasons, hence adding it after install is required.

yeah i understand not providing the codecs bundled with the install. I meant having the repository. It’s still unclear to me as to why there are 2 sets of codecs, but half works, and the other doesn’t. This is all very confusing to me. GO the thumbnails but didn’t get the sound though :confused: I’ll just stick with mplayer haha, that was tough :slight_smile:
Thank you much

You’ll find the same situation on most of the big distros. Restricted formats have to be enabled by the end user.
Try and enjoy openSUSE, it’s a great OS