How to get to my mp3 files

I have installed opensuse 11.0 on my computer. Can boot either way, Opensuse or windows. How can I access my windows files such as mp3 with opensuse?

Its simply a matter of mounting the appropriate partitions on your hard drive. A few shell commands should do it.

Before we go too much further just double check it hasn’t already been setup by the installation (its been a while since I last built a dual boot system) you may find that there is a directory called /windows).

Check the output of ‘ls /’ and ‘mount’ for anything that seems appropriate.

Is the windows partition mounted already, if so you should be able to
access via /windows/C else have a read here;

HowTo: Mount your NTFS
Filesystem/Partition for Read/Write Access in openSUSE 10, 11

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel
up 1 day 11:47, 1 user, load average: 2.47, 1.40, 0.65
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.82

If you post your:


and then from a su terminal do:

fdisk -l

Post it all here and we can help you further

@pjww please don’t double post. It makes some of us strange. I’ll merge the two threads for you before I reach for the bottle of calm :wink:

There is a program called " ntfs-config " that will mount your ntfs windows partition and set permissions with a few simple clicks of the mouse.
Goto yast software management search for " ntfs-config " install then start it select your windows partition and it will mount it in the media folder with read-write permission for normal user.

I’d like to say mp3 is not windows file. (Expecting they are in /windows) :slight_smile: Whatever, after following the above instructions you are probably able to find your mp3 files. Now install any media player like VLC or gmplayer. you’ll be able to play them. Or simply click on the files (when you have internet connectivity) and the player should try to look for mp3 codecs. Let it find and install the codecs.

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1549f232

Device Boot Start End Blocks Id System
/dev/sda1 1 765 6144831 c W95 FAT32 (LBA)
/dev/sda2 * 766 19457 150143490 7 HPFS/NTFS

Disk /dev/sdb: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0bea0be9

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 11780 94614817 7 HPFS/NTFS
/dev/sdb2 11780 14593 22603424 f W95 Ext’d (LBA)
/dev/sdb5 11780 11863 674698+ 82 Linux swap / Solaris
/dev/sdb6 11864 11947 674698+ 82 Linux swap / Solaris
/dev/sdb7 11948 13021 8626873+ 83 Linux
/dev/sdb8 13022 14593 12627058+ 83 Linux
Patrick:/home/patrick # mount -t ntfs-3g /dev/sda2 mnt/windows
ntfs-3g-mount: bad mount point mnt/windows: No such file or directory
Patrick:/home/patrick #

This is what I did and this is what I get. baffled i am

You need to make the windows directory under mount (if it isn’t already)

mkdir /mnt/windows

Also, you are missing the first / in your mount point, should be /mnt/windows, not mnt/windows.

However, it might be easier for you to do this through Yast. Just start Yast, go to System and choose partitioner. Then you just have to choose your partition (looks like sda2) and choose edit. You can set a mount point there (DO NOT FORMAT it!!!). This will add it to fstab so that it will automatically be mounted at boot time.

As @caf4926 suggested above, you really should post back your /etc/fstab file first. The Windows partition may already be being mounted, you need to know what is in that file.

Thank you. Used yast like you suggested. Worked. Just read your second replay. Do I need to be concerned since i used yast and it worked? One question i have is now that i can get to the files from windows, are they moved to another spot on my harddrives?

Your files have not moved. They are just where they always were.