How to get out of metacity?

I’m still having a lot of difficulties with 11.2 KDE. None of the video players work properly (and I’ve installed quite a few in hopes of lucking up on one that’ll work); OOo kept crashing, so I uninstalled it and installed Abiword – it kept crashing too. So I tried to install the Gnome desktop with hopes that it would work better. But it doesn’t show up anywhere!

The login “station” when you all boot doesn’t happen on my 11.2 – the system would bypass that (but wants root verification for every little thing else); so I never got the chance to select a Gnome session. But at some point, it occurred to me that maybe if I just logged out instead of restarting, maybe it would take me to a login “station” (I don’t know what the actual term for it is) where I could choose Gnome.

Well logging out did take me to a login station, and there was a session menu – but no Gnome option. So I chose Metacity; somehow, I associated that with Gnome. I logged in and it took me to a blue screen with nothing else on it. I had to do a hard reboot to get out. I’ve tried all the listed boot options, but I always end up back at the blank (now black) screen with nothing but a mouse pointer on it. I even used a failsafe pae boot option to get to a red prompt and entered zypper dup in hopes that maybe when it got done the system would boot to KDE. No luck there.

What to do now. Presently, I’m using PCLinuxOS to post this.

Any help will be much appreciated. What would be the Zypper command to install a Gnome desktop?

Console login
Maybe disable compiz will do it
Compiz Fusion - openSUSE

Compiz Fusion - openSUSE gives the following instructions for disabling Compiz:

“For GNOME or KDE run Desktop Effects(simple-ccsm) application to enable/disable Compiz.”

I’m not clear on what that means. Preferably, I’d like to know, verbatim, what to put on a command line.

I apologize for always being inept. Help is always much appreciated. Thank you.

From what I read in su terminal

xgl-switch --disable-xgl

For KDE :
**kwriteconfig --file ~/.kde4/share/config/kwinrc --group Compositing --key Enabled --type bool false
I wrote a simple script, since I had to do that too often. Tested under Ubuntu and openSUSE.
Syntax : scriptname on|off .

#! /bin/bash                                                 

# error function
function error() {
echo "$1"

prg=`basename $0`

# get user config path
cfgdir=`kde4-config --path config | awk -F ":" '{ print $1 }'`

arg=`echo $1 | tr ":upper:]" ":lower:]"`

case $arg in
on|1|yes) val=true ; pre=en ;;
off|0|no) val=false ; pre=dis ;;
*) error "syntax: $prg on|off"

if  "x$cfgdir" == "x" ] ; then
        error "KDE config path is empty. Check your KDE installation"
elif  ! -d $cfgdir ] ; then
        error "KDE user profile not found. Reinstall KDE for user $USER"
        if  ! -w  $cfgfile ] ; then
                error "$cfgfile not found or not wrtitable"
                kwriteconfig --file $cfgfile --group Compositing --key Enabled --type bool $val && echo "Desktop effects ${pre}abled"

I ran the script and after a few seconds, output came saying “desktop effects enabled.” I restarted and I’m still stuck in Metacity.

Nonetheless, thank you very much for your efforts to help me. I appreciate it.

This script enables or disables Desktop Effects in KDE. It has no effect on Metacity, which is Gnome preferred window manager. To disable desktop effects in Gnome, remove (or rename) the directory ~/.config/compiz.

You might also have to disable compositing in Metacity if it has been previously enabled.
gconftool-2 --config-source xml:readwrite:$HOME/.gconf --type=bool --set /apps/metacity/general/compositing_manager false
gconftool-2 --direct --config-source xml:readwrite:$HOME/.gconf --type=bool --set /apps/metacity/general/compositing_manager false

should do it.

No, there is no need to remove the directory, to disable compiz all you
need to do is;

rm ~/.config/compiz/enable-compiz
touch ~/.config/compiz/disable-compiz

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1 day 12:26, 2 users, load average: 0.09, 0.05, 0.05
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Good morning (or afternoon, for some).

Got up this morning with a clearer head and realized that what I’d said was the output following

kwriteconfig --file $cfgfile --group Compositing --key Enabled --type bool $val && echo “Desktop effects ${pre}abled”

couldn’t be correct. So I went back to pae failsafe and tried it again so I can tell you what it actually said, which is “desktop effects abled,” whatever that might mean.

When I go to personal settings>configure desktop, the window only actively shows the words “Configure desktop effects,” and “General,” along with a blue circle with an “i” on it saying: “Compositing is not supported on your system. Required X extensions (X Composite and XDamage) are not availble.” Everything else is grayed out.

So would that mean that Compiz wouldn’t need to be disabled? Since I was in the neighborhood, I did zypper help looking for ideas. Zypper rm metacity did it for me. So right now I’m posting from openSUSE 11.2 pae – I assume the default option will work, too. If not, pae is just fine.

That don’t mean, however, that 11.2 KDE is alright, now. I have no reason to think that everything that didn’t work before yesterday works now. I still have to go over to PCLinuxOS to use a word processor, for example. How’s the GNOME desktop faring?

To everyone: Thank you so much for the timeliness of your help and the willingness and creativity put into it.:slight_smile:

Luv ya

No, wait. I forgot – I’ve already tried to install the Gnome desktop but don’t see hide nor hair of it. How do I get it to pop up as a session option?

First off, you don’t need compiz at all in kde. Kwin provides effects if your system can support it.

PAE is not necessary unless you have more than 3GB RAM on a 32bit system. That’s not to say you can’t use it, you can. Desktop or Default kernel would be the norm. And mostly you would only have one kernel installed, not all of them.

I’m using the Gnome desktop. I went to Yast, package groups, Gnome desktop, and selected everything I thought might help enable a Gnome session option. I had considered selecting everything, but decided against it, thinking of the increased likelihood of conflicts. So I can’t tell you which one or two actually did the trick for me. While the desktop isn’t as bloated and slow as the KDE, a lot still doesn’t work. Oh, well.

I’m thinking that I had deselected for removal the virtualbox default driver, thinking that I didn’t need it. But when I marked it for removal, Yast selected another one to be installed – I think that’s where the pae kernel came from. And thankfully I did have it, else I’d of had to throw in the towel on 11.2 because it was the only boot option that allowed me a command line prompt.

I tried to give some of the folks who responded to this thread some reputation, but it said I had to spread some around else where.

I have a couple of other active threads here, and see myself starting a couple of more.

Again, thank you so much.

Indeed. You can not just paste a line of a script and execute it out of its context. In your case none of the variables is defined. Either you run the script by typing: scriptname off (where scriptname is the name you gave to the file containing the script) or you use the following command:

**kwriteconfig --file ~/.kde4/share/config/kwinrc --group Compositing --key Enabled --type bool false **

Again, it affects only KDE, not Gnome and Metacity.

You should see metacity as a ‘part’ of Gnome and never remove it. If you boot in runlevel 5 (which is the default), you should see a graphical login script, where you can choose the type of session (= the kind of window manager you want to start). There are other possibilities than KDE and Gnome. Any other WM will be less fancy but much faster. icewm-lite is installed by default. It’s extremely light weight and doesn’t have many features. Rather install the ‘regular’ icewm by typing** zypper in icewm**. The package icewm will replace icewm-lite as the icewm default. Then, next time you see the login script, choose icewm session. Everything should be much faster. You can later use Gnome or KDE once you have solved your problems.

You could also boot in runlevel 3 and start X from the console by typing: init 3 or gdm or startx… or xdm or kdm (provided those are installed).

Thank you.