How to get Java to not need root user to run web application?

I followed the instructions from here to get Oracle java running because an application I need wouldn’t run reliably with openjdk. Once I got it installed (/usr/java/jre1.8.0_152/) I had the problem that the app (a .jnlp file) would seem to start and then java would give an error:

Unable to launch the application.

After playing around with Java permissions with no change in result I thought I would try running the app. as the root user (using Dolphin in root user mode) and sure enough the app. started just fine.

Clearly I should not need to be root user to run applications so does anyone have any idea what I would need to do to make these web Java apps. run as a normal user?


That’s probably because your java application files are in a location that requires root permissions.

Place your app files in something like ~/Documents and then try invoking.

If that doesn’t work,
Then you’ll have to provide details about the web application and the file location.


The app. was originally in the temp. dir. that FireFox downloaded it. As a test I moved it to ~/Downloads, made sure its owner was me, which it was anyway, and then tried to run it. I had the same error. The application is AdvancedPlanner.jnlp from .

It starts up fine from my Windows laptop from FireFox and it started fine before I installed and made Oracle’s Java the default in my Leap computer (it just didn’t run reliably).

Need complete details…
Download from wherever.
command you’re running to invoke.
And, possibly (but maybe not necessary) any references and/or documentation you’re following.

BTW - following says should be invoked with a sh script and not a java command. If you really wanted to invoke using a java command, it’s probably in the script


I think I have given you complete details on what I did:

  • I setup Java according to:
  • I setup the the Java version: jre1.8.0_152 and Java installed itself at: /usr/java/jre1.8.0_152/
  • I downloaded the app from: probably won’t be able to do so without an account with them)
  • Invoked it by clicking on the downloaded file through Dolphin and before that just tried to launch it through the browser which is the normal way. It’s started with javaws which is Java Web Start as far as I know, I am not an expert on Java by any means.

All of the above is already in the previous posts and there isn’t anything else to tell that I know of but by all means feel free to ask for more information if I have left something out.

what happens if you do start it as root and then try to access the app in a browser ?

I’ll take a few minutes and look at this, but your “Download” link doesn’t point to a download page or a file… It points to the cloud login page.
Would also be useful if you can provide the <exact> file name you downloaded (It’s probably a zip file that needs to be unpacked).

And FYI -
Generally, if you really did try to “run” a java app, double-clicking in Dolphin(or any other graphical file manager) won’t execute the file properly.


I don’t quite understand the question. When I start it normally as the root user it is a Java application independent of the browser, I’m not sure what going to the browser at this point achieves?

The reason I can’t give you an exact link is because the link is only accessible by logging into our account. The accounts are free (for 30 days) and you can create one in minutes but I can’t give you our link, I don’t have the authorization to make it public and if I did it would be useless without the login information. This is why I gave the general link, it was the best I could do. Here is the downloaded file though:

:~> ls -al Downloads/AdvancedPlanner.jnlp
-rwxr--r-- 1 reg users 2970 Nov  7 01:18 Downloads/AdvancedPlanner.jnlp*

And FYI -
Generally, if you really did try to “run” a java app, double-clicking in Dolphin(or any other graphical file manager) won’t execute the file properly.

I don’t know what to say about this, I guess I just got lucky that it would start by the root user at least.

Is it a correct assumption that, you’re attempting to run an “Advanced Planning and Scheduling” Java application (possibly from ‘IBM Rational’) which absolutely needs Oracle Java to execute correctly?

Which begs the question: is it really a “Web Application” or, is it a Java application which accesses resources via the Internet?
[HR][/HR]The reason I’m asking is, I use a Java HBCI application which has run perfectly for years without any “need to use root” issues – despite a phase where, the Java code wasn’t so happy with OpenJDK and I had to use Oracle Java to work around the issue but, that’s past history – the application has been running quite happily for the past few years with OpenJDK.

Another Java application I have, which was used for maintenance of an ISDN telephone switch (since the change to VoIP, it’s been retired), had to be executed from the user “root” because, it used a USB cable with a private protocol to access the ISDN hardware – no big issue – and, actually, perfectly normal within the telecommunications industry.

@dcurtisfra This is a different company. Their application is a MS Project competitor written in Java and I don’t know much more than that except they told me not to run it in OpenJDK and once I ran on Oracle Java the problems went away, other than the root user thing.

I have little doubt that the root user problem is an installation problem with Java - it should be possible to run as a normal user with a proper installation. There’s probably just some file somewhere that needs it’s ownership or permissions changed but I have no idea how to track that down.

A JNLP is not a typical java app, it’s a java applet packaged within a “Network Launcher”

I haven’t run a JNLP recently,
But a quick Google search suggests that you can use the Oracle Java Control Panel to modify security settings.