How to get grub2 to boot from an iso in an lvm volume

I am trying to upgrade my opensuse 12.2 server.
Most of the disks are formatted with LVM that I want to preserve.
I only have space for the dvd iso in the LVM volumes.
So, can I get grub2 to boot from an iso image in an lvm volume?

The lvm volume is mounted by specifying the device as /dev/LV_ALL/nas mounted on /nas in /etc/fstab.
“grub2-probe -t device /nas” results in “/dev/mapper/LV_ALL-nas”

I have tried this in /etc/grub.d/40_custom…

menuentry "openSUSE 13.2 DVD" {
  insmod lvm
  set isofile=/software/openSUSE-13.2-DVD-x86_64.iso
  set root=(/dev/mapper/LV_ALL-nas)
  loopback loop $isofile
  linux (loop)/boot/x86_64/loader/linux install=hd:$isofile
  initrd (loop)/boot/x86_64/loader/initrd
}

But I get this when trying to boot this entry…

error: disk `/dev/mapper/LV_ALL-nas' not found.
error: disk `loop' not found
error: you need to load the kernel first

Any ideas? Thanks!

grub is not Linux and it does not understand Linux device names. Go to command line in grub, do “insmod lvm” and then “ls” - it will show you names of detected volumes.
Here are example of LVM names in grub:

(lvm/system-root)
(lvmid/F1ikgD-2RES-306G-il9M-7iwa-4NKW-EbV1NV/eLGuCQ-L4Ka-XUgR-sjtJ-ffch-bajr-fCNfz5)

Fantastic - thanks.
I know have grub2 successfully finding and running the kernel, but then the kernel cannot find the installation media.
What parameters do I have to place in the “linux” command line.
I currently have this in /etc/grub.d.40_custom…

menuentry "openSUSE 13.2 DVD" {
  insmod lvm
  set isofile=/software/openSUSE-13.2-DVD-x86_64.iso
  set root=(lvm/LV_ALL-nas)
  loopback loop $isofile
  echo    'Loading Linux from isofile ...'
  linux (loop)/boot/x86_64/loader/linux root=/dev/mapper/LV_ALL-nas install=hd:$isofile
  echo    'Loading initial ramdisk ...'
  initrd (loop)/boot/x86_64/loader/initrd
}

My guess is the “install=” setting is at fault.
Thanks in advance…

root= is definitely wrong here. Otherwise I can’t say - it works for me if I pass install=http://…; I do not have full DVD install image to try ISO. Can you select ISO file manually?

No, I have tried a ton of options but cannot seem to get the right incantations to the linuxrc command! Have spent a lifetime reading
SDB:Linuxrc - openSUSE Wiki and other pages, all to no avail!

Note that booted installation kernel must be able to access ISO image as well. For all I can tell, LVM is not part of initial RAM disk; so I’m afraid what you try is not possible. Put ISO on plain partition with ext2 filesystem to be absolutely sure.