How to get "flash" in TW???


Out of my 5 linux distros TW is the only one that I couldn’t flog into getting “flash” going so that videos can be played, or even yesterday instead of showing an animated .gif in FB . . . just a white space. Same in Twitter where someone . . . posted a video . . . only a white space with “nothing to see here” . . . so like every other tweet.

I tried a few of the usuals “pepperflash” and I looked through yast for “flash player” . . . nothing shows up there.

Plz help.


AFAIK it’s a dead/insecure product…? Tell the folks to use something else…?

This may help?


OK, well that has been said before, but then what are for example you using to look at animations that don’t require launching a separate app each time, etc?

I’m not booted in TW right this moment, but I believe that I tried to “add the plug-in” via Firefox . . . but seemingly that “didn’t work” in TW, but it did in others, probably the ubuntu flavors???

It seemed that TW was “resistant” to getting “flash player” going???

I was under the impression that the later versions of Firefox don’t have support, looks like the end user needs to enable: end of the year it will be no more…

Alrighty, well that does jive with the idea that this has been in the tubes for a couple of years . . . . So, one assumes that people aren’t going to stop watching videos online . . . because it seems “popular” . . . ???

So, will FF be coming up with their own “flash” item?? Or, FF will just be able to seamlessly run videos across the various platforms???

I am installing flash from the packman repo.

If you have configured that repo, they do show up in Yast.


Thanks for the reply . . . I’ll have to check on packman repo . . . . I’ve had LEAP and then went to TW, and then had some troubles with it and I think I had to do anoher fresh install of TW some months back and maybe I didn’t add the packman repo . . . ??? But I think it might be there, since at one point I was trying to add “nvidia” drivers . . . before I went to “default” video . . . I think “nvidia” needs packman as well right??

So, if packman is there then I would be running “flash” in Yast and it would pull the packages? Or, it’s some other search phrase?? I recall awhile back running a bunch of search terms through Yast . . . “nothing found” was the usual reply of the day.

I just searched “flash” on a system with Packman repo, and nothing related to what we’re talking about showed up.

You might try installing Adobe Flash Player directly from Adobe

Keep in mind,
Not only is the technology dead and gone, it’s also a recognized one big security mess, highlighted by a major feature “flash-cookies” which should not be confused with regular website cookies. Regular cookies are text only files every Developer knows not to store sensitive info and are only good for storing text data. Flash cookies on the other hand has been heavily abused extracting and transferring personal data on numerous occasions.

Every website that deploys videos can convert to playing their videos in alternative players, most commonly HTML5 player which don’t requrie plugins and proprietary code. YouTube did it. Their entire library of content used to be served in Flash, now is commonly played in HTML5 players.

The website just needs to hire someone to do the re-coding although I understand that it’s likely corners were cut that allowed the use of Flash in the first place.



Well, yes . . . that matches up with what I found in Yast some time back while trying to get something to play videos in TW. It seems well known that “flash” is a problem . . . and it isn’t exactly “flash” that I care about . . . it’s simply being able to use TW AND be able to see videos and/or animated .gifs . . . rather than white space . . . while in the browser . . . i.e., not copy/pasting a link into another app just to see a twitter feed video, etc.

I have some of my FF’s with some “HTML5 to Flash” toggle plug-in . . . but so far I haven’t had to mess with it, as far as needing to signal “HTML5” to watch videos . . . I guess that’s because “flash” is still working until the end of the year??

But again, it seems to be only TW that is showing these blocks of empty whiteness wherever a video is posted . . . and for the most part I don’t spend hours looking at videos, but yesterday was “TW day” . . . and I had to reboot out of it to just see what was in the empty whiteness of a social media post . . . .

That’s what drove me to inquire here about how to get TW firing on all 8 . . . .

Here is a link to the packman packages: I would download from here and manually install if you really need it, but at least it’s good for a few more months. Maybe have better luck in a different browser?


So, I couldn’t take the pressure of not knowing, so I rebooted back into TW partition . . . and I launched Yast and searched “flash” . . . and top hit is showing “adobe flash player 32” as “installed.” !!!

Then I launched FF and it opened up to the FB page that I had problems with yesterday . . . the .gif image that I saw in . . . manjaro . . . flashed for an instant and then went “white” . . . I looked up in the toolbar it it shows a “5” icon for “html5” . . . I clicked on it to change it to “F” for “flash” and again the image flashed on the screen . . . then went white???

So, it seems like “flash player” is installed and the 5/F toggle plug in is also installed . . . but something perhaps in TW is “killing” the “flash”???

Also, thanks for the link to the flash-player packages . . . but seems like it just opens this thread in another window??? I didn’t check the second link yet . . . but it does seem like TW has “flash” but it just “flashes” before choking off the vitality of the animations . . . into whiteness . . . .

[edit: checking the repos doesn’t show “packman” in TW, so would that be an issue with flash not working??]

Figured my way through the Yast software repo . . . and I added “packman” that way . . . then ran zypper . . . seemed to show “packman up to date” ??? even though it was just installed . . . . Pulled about 48 upgrades, rebooted . . . launched FF . . . went back to my FB .gif tab . . . .

Problem remains . . . image loads briefly before being white-washed . . . toggled back and forth from 5 to F . . . same thing . . . .

So, maybe a couple more clues . . . back in TW and still finding “media can’t be played” over posted media . . . in one such item there was a “install adobe flash” button . . . so I clicked that and selected rpm package . . . to be opened by Yast software . . . it opened it and showed a list of items that were blocked, such as nouveau and a few others . . . .

With guidance from the list here this install is not using nouveau for the video driver and some packages were “locked” to deal with some problem possibly with nvidia . . . so those were the listed “dependencies” for flash . . . and then flash itself was marked for “reinstall” since it’s installed . . . .

I clicked “go” . . . but then Yast said, “package is corrupt and didn’t pass review” . . . so I cancelled out of it . . . . Possibly I could have forged ahead on installing that, but then all of the other packages were “tabbood” . . . .

So, I’d have to try to find the thread where we made the decision to lock those packages . . . upgrading them at the time caused some problem . . . but it’s been awhile. Overall the function of the “default” video driver . . . i.e., non-nouveau . . . has been fine . . . only this problem with not showing videos an gifs is . . . unique.

The following 5 items are locked and will not be changed by any action:
at-spi2-atk-common at-spi2-atk-devel at-spi2-atk-gtk2 brltty-driver-at-spi2


Tagging you because you helped me with the “zypper al” commands to lock those 5 packages . . . . I searched the thread and bug reports and saw that apparently those bugs were fixed in April of this year, perhaps not long after I had posted the other thread with the “at-spi -xxx” packages that we locked.

So, as mentioned when looking at “flash” in Yast it showed the 5 locked packages marked as “taboo” . . . and it’s not clear if they offer some dependency to get flash working . . . but right-clicking on the taboo items in Yast wasn’t giving me a drop down menu to select “unlock” . . . and then trying to get one of them to unlock, actually seemed to “crash” Yast??? Yast became unresponsive . . . to clicks and commands . . . so I think I shut down.

Today I searched the googly to find out the zypper command to “unlock the packages” and it showed “rl” . . . so I ran:

sudo zypper rl at-spi2-atk-common at-spi2-atk-devel at-spi2-atk-gtk2 brltty-driver-at-spi2

It came back as “one package unlocked” . . . which I think was the “britty-driver-xx” package . . . I tried it again and “No packages were unlocked” . . . I then ran zypper ref/dup -l . . . . Have yet to check to see if Yast will show these locked packages or try to install flash, even though it shows that it is installed . . . we get “media could not be played” for all videos in FB and twitter . . . .

The locks are in a file “/etc/zypp/locks”. It’s a text file, and if you remove the file that removes all package locks. But it is unwise to remove while running “Yast” or “zypper”, because they might be using the lock file.

I’m pretty sure that the videos on FB and twitter do not use flash, though they might be able to use flash as a fallback. If those videos are not playing, you are missing some multimedia libaries and/or codecs.


Thanks kindly for the reply . . . OK, there is a text file . . . I had 5 packages locked, including “nouveau” because I was following forum advice to go “default video” . . . so I wanted to keep nouveau locked, but unlock the 4 others, now three others that remain locked . . . .

Can I use a text editor to edit out the three “ati” files and leave the nouveau in the file . . . OR, would I have to trash the whole file, then relock nouveau???

And, OK, “missing multimedia libraries and/or codecs” . . . yes, please, I definitely am missing out on the multimedia experience in TW . . . . How would I go about finding out which packages I would want to add into the Tumbling Tumbleweed mix???


Alrighty, had to use nano to edit that file, but the mesa-dri-nouveau stayed locked, but the other packages are cleared of locking . . . . Since I already ran zypper once or twice today . . . nothing to do.

But still would be interested in getting the multimedia thing going . . . .

Went over to Yast . . . typed in “flash” . . . this time a bunch of other packages showed up, only one I recognized was “flash-player” . . . . Yast added that package, didn’t suggest any other dependencies . . . .

Logged out, and launched FF again . . . Twitter still won’t play the videos . . . if I click on the blank spot saying “media can’t play” the video flashes for a second, then back to white . . . .

Is this something where going to nouveau driver would provide the packages to get multimedia and videos going???

Did you try following the sticky multimedia guide thread:

Yes, it says “15.1”. But I’m pretty sure I didn’t do anything different for 15.2 or for Tumbleweed. The packman repo url for 15.1 will be wrong for you, but I think you have already added that repo.

Maybe just switch all system packages to packman, and then try adding the suggested packages (you will already have many of those).


Thanks for that link . . . that does seemed to have worked!!! I have moving pitchers in twitter . . . . I tried to use the gogalthorpe method of “zypper --from #5” (in my case) but that didn’t work . . . . So then since as you say I already have packman . . . I added the

Repository 'libdvdcss' is up to date.                                           
Repository 'Packman Repository' is up to date. 

libdvdcss item . . . then copied/pasted all of those packages in the terminal . . . then followed the advice to run it through Yast . . . clicking “package switcher” . . . . Rebooted and everything seems to be operational . . . and, now, “multimedia moving images” . . . .

Very cool. I guess my question is, why isn’t some rudimentary video capacity installed with the base system in OpenSUSE?? Seems like mostly what the common folke are doing is . . . social/multimedia???

But, thanks for providing that link . . . worked out. I tried to run a follow-up “zypper ref/dup” to see if that would run through ok, but . . . “nothing to do” at this point.