How to get ethernet working on install for a motherboard using Realtek 8125 2.5Gbps chip?

Hi all,

This 8125 ehternet chip is becoming very popular on enthusiast motherboards, but to my knowledge there is no kernel support yet for this chip.

Right now, apparently we have to install the driver from the realtek site:

A couple of questions:

  1. What would be the recommended method of installing [this] driver download on Tumbleweed?
  2. How would [you] choose to get driver support for this chip? i.e. can it be packman’ed…
  3. The driver page says driver valid up to kernel 5.6, is it likely that native kernel support will arrive soon? i.e. with 5.7…

Many thanks. Jbt

Not sure if will be in later kernels… anyway here you go;

RTL8125 / RTL8125B(S) becames very popular.
Hope it will be integrated into openSUSE’s distribution.

I see

  • maybe we already have all that we need?

RTL8125 appears in market in October, 2018.

thank you, all.

i hope we do have what we need, but:

Is this something that will be rolled into the image, or something we’ll have to install from (a separate) network connection?

p.s. thank you to Malcolm for rolling that driver (?) in the last four days. :slight_smile:

I would recommend downloading and installing, if/when kernel updates you will need to grab the updated kmp… In time hopefully it appears in the kernel…

Linux kernel has support for RTL8125 since 5.4:

@OP, do the PCI id’s match 3000 or 8125? If so, then should be good to go with the r8169 module (Why they put in there, have no idea…).

/sbin/modinfo r8169 | egrep "8125|3000"

firmware:       rtl_nic/rtl8125a-3.fw
alias:          pci:v000010ECd00003000sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008125sv*sd*bc*sc*i*

thanks, OC’ers mucked up my order, so rather than have it built today i’m gonna be waiting a week or so. will let you know when i’m built.

flood of boards being announced with this ethernet chip between amd X570/B550, and intel 460/490 boards.

the ehternet chip used is the 8125b variant. thank you. Jbt

[HR][/HR]An update:

I installed 20200731 and it did not configure the 8125b network chip.

The install process could see the intel wifi ax200 chip - which isn’t used on my network - but showed nothing for the ethernet hardware.
Flipping the tab onto the ethernet section of the install page showed nothing that indicated TW was aware of the hardware.
Getting to the desktop after the install predictably resulted in no network access.

Something is not right with the 8125b…

Kind regards. Jbt

Maybe try this one:

Looks like it also needs firmware…

cheers, i was just about to post that link here.

fingers crossed asap.

and bugzilla report to package up the firmware:

just had a b550 itx board delivered with 8125b to add to the x570 atx board which i’m already using…

looks like the 8125 firmware will arrive with kerel 5.9:


thank you, devs!](

I have tried Open Media Vault with kernel 5.4 and it did not work with RTL8125 until a patch was added. I would think an NAS is one case where you would want faster ethernet cards.
There are now more linux distros with newer kernels. openmandriva with kernel 5.5 works with RTL8125. Fedora and Manjaro also have kernel > 5.4, but I don’t have enough cards to try them all. I ordered some more, but freight is so slow with COVID-19


I have the same issue as OP. Network isn’t working, so I transfer files from another computer via USB. I downloaded the driver from RealTek’s website but need certain packages in order to compile it with the kernel until it is included in opensuse. I installed Tumbleweed yesterday which is at version What packages are needed to manually install the driver? The DVD iso did not include a base devel pattern, so I chose make, gcc, etc. I manually installed kernel-source. but when I try to install the source, it says nothing provides kernel-devel. The package search (✓&baseproject=openSUSE%3AFactory&q=kernel-devel) returns no kernel-devel package. I am new to opensuse, so if this is a pattern that needs installing, how is that achieved?

Add this Repo:
and install r8125-kmp-default.

This rpm is build with the source from Realtek

You need gcc make kernel-devel kernel-default-devel

Thank you very much Sauerland! That worked perfectly!