How to get acconaut/root password

Hello!
I got a bit old notebook from my dad, because my NTB is broken. :frowning:
This old NTB has got win xp and Linux 3.12.67-64-desktop openSUSE 13.1 (Bottle) (i586).

When I close the lid or let the computer into sleep mode, I can’t login back, because my dad can’t remember password.
And I can’t install anything because IDK “root” password…

How can I get it back?
I’ve tried googling and searching settings on my pc and similar posts here without any sucess.

Thanks for help

You can’t, except by trying out all possible character combinations (aka “brute force attack”)…

It is quite easy to change it though, if you have physical access.
Just boot with the “init=/bin/sh” boot option, and you will get into a minimal text mode system (as root).
Run “passwd” there, and change it to anything you like.

As root, you can also change user passwords, or just create a new user account.

Or do a fresh installation.
13.1 is out of support since years.
Current Leap versions are only available for 64bit systems though, so they are no option if the CPU is 32bit only. (most CPUs manufactured in the last 10 years are 64bit, but I don’t know how old your father’s notebook is)
Tumbleweed (the rolling distribution) is still available for 32bit as well though.

Okay thanks

How can I boot with the “init=/bin/sh” boot option?

and I have 32 bit CPU

Press the ‘e’ key at the boot menu, append it to the line starting with “linux”, and press F10 to boot.

and I have 32 bit CPU

Then Leap is no option for you.

But are you sure about that?
The command “lscpu” should tell.

If I press f10 now, system normally boots and I can’t change the password.
https://lh4.googleusercontent.com/1vQVr7DfDfZ21qVBtNEMnAdFZvj1_ZU-abV-FuSAyc3rtK_wIpQSyJUMkFS9ICY6yltv0NxSKf9RDTEEb78wBB8qPM4RlG50-R11=w1366-h650
What I need to do?

And I have 32 bit cpu for sure :smiley:

Did you follow Wolfi’s instructions exactly? I.e. hit “e” at the boot menu, then append the described command to the line that starts with “linux” . That shouldn’t boot the system “normally”.