how to get a desktop after a mistake with ATI drivers

I am not certain of the cause (it may have been after I updated my ATI video drivers, or instructed my system to use a dual-head configuration, which in hindsight was perfectly dumb) but regardless of the reason–now when I “startx” my monitor freezes with a few stray motionless pixels. Nothing I’ve done helps: tried “sax2 -r -m 0=fglrx”; tried “aticonfig --initial”; tried to revert to an earlier xorg.conf; but I don’t really know what I’m doing, so I hope someone who far surpasses my knowledge of SuSE on the command line can help me out.

How do I get my desktop back?

(OpenSuSE 11.1 on a dual-boot iMac, ATI Mobility Radeon)

Thanks in advance!

This worked for me:

  1. boot to a console by pressing numeral 3 at the Grub prompt and then pressing enter
  2. log in as root [Be careful not to make a mistake as root in a terminal window with the commands below]
  3. now delete xorg.conf with
rm /etc/X11/xorg.conf
  1. reconfigure in low res vesa mode with this:
sax2 -m 0=vesa
  1. Then reconfig using the vesa form of xorg.conf as a starting point, this command:
aticonfig --initial --input=/etc/X11/xorg.conf
  1. reboot

Might fix it, can’t hurt it

Thanks, Swerdna. I tried your suggestion. First of all I can’t get into the console at the Grub prompt. That may be why the next steps don’t work properly. So I boot into FailSafe mode, and then at the prompt I can “su root” and run the following “sax2 -m 0=vesa”. The result, though, is a blank screen. That command produces a video test, doesn’t it? I can’t get past that point.

Maybe my video drivers need to be re-installed, do you think?

> Maybe my video drivers need to be re-installed, do you think?

Sounds like the driver is botched completely. Do you have the ATI repo
installed? If so maybe you could run zypper up and see if it will fix it.

I do have an ATI repository listed, and the following ATI packages:

fglrxG01-kmp-debug
fglrxG01-kmp-default
fglrxG01-kmp-pae
fglrxG01-kmp-trace
fglrxG02-kmp-debug
fglrxG02-kmp-default
fglrxG02-kmp-pae
fglrxG02-kmp-trace

None were updated with “zypper up”. What would happen if I just removed them all? How would I tell the system not to use ATI drivers when starting the desktop? Are there basic default drivers that could be substituted? If this was possible, it would remove a big possible variable for my current problem.

A bit more peripheral information please:
Is this a clean installation of openSUSE 11.2 or an upgrade?
Please run these commands and report the responses:

  • rpm -qa | grep fglrx
  • uname -r
  • ls -l /etc/X11/ | grep conf
  • lsmod | egrep “fgl|rade|ati”

This is OpenSuSE 11.1. I’ve been using it for about a year. It was installed from scratch.

Results of console commands:

rpm -qa | grep fglrx
ati-fglrxG01-kmp-default-8.593_2.6.27.37_0.1-15.2
ati-fglrxG02-kmp-debug-8.661_2.6.27.37_0.1-21.2
ati-fglrxG02-kmp-default-8.661_2.6.27.37_0.1-21.2
x11-video-fglrxG02-8.661-23.2
x11-video-fglrxG01-8.593-16.1

uname -r
2.6.27.39-0.2-default

ls -l /etc/X11/ | grep conf
There are a lot of backups listed because of the number of attempts I was making to fix the issue. They are all “xorg.conf.fglrx” with different suffixes, e.g., “-0” through “-5” and “-post” and “.install”, “.md5”, “.original-0”, and “.saxsave”.
Also a couple other files: “XF86Config -> xorg.conf” and “myxorg.bak”.

lsmod | egrep "fgl|rade|ati"
fglrx 2247992 0

You should have either this set:
ati-fglrxG01-kmp-default-8.593_2.6.27.37_0.1-15.2
x11-video-fglrxG01-8.593-16.1

or this set:
ati-fglrxG02-kmp-default-8.661_2.6.27.37_0.1-21.2
x11-video-fglrxG02-8.661-23.2

So use Yast to uninstall all but two. I don’t know how to choose the appropriate set (GO1 or GO2) but maybe it depends on your video card or maybe someone who understands ATIO cards can tell you, or you could try one set tand then the other if the first set doesn’t work.

I personally would do this: uninstall ALL of them and then go back to Yast and see if it’s trying to install just one set GO1 or GO2 all by itself (it has a tendency if they’re all gone, to then try to reinstall the correct ones).

If you have no GUI just boot to a console and enter su to be root and the enter yast to get the old version of Yast, that works very nicely.

Swerdna, that worked. Thanks for helping me. I removed all ATI packages using the old Yast interface and then rebooted. I was able to start the desktop. I added only the G01 packages (figuring they are older and were probably the version I was using beforehand).

One wrinkle is that after I re-installed the ATI packages and logged in again, all application windows were rendered without their title bars and they were squeezed up to the top left of the monitor. I couldn’t move them or use the controls normally found in the title bar. I suspected that this was a problem with Compiz, so I removed Compiz and that worked. But I would like to have Compiz, so I’m not sure what to do now other than to re-install Compiz and see what happens.

Good luck – if it doesn’t work it might be time to mention “xmas presents” and “video cards” in the same sentence to a family member lol!

Ah, well, that won’t be happening since this SuSE is on an iMac. I’ll dispense with it on this one, but I have other machines that can handle Compiz quite well.