How to get a Canon PIXMA iP1500 to work

Hi, I just acquired this printer. I would like to get it to work with my laptop.I’m running OS11.2 I’ve looked in yast but it isn’t listed. Looked in Canons website and didn’t find a driver for linux.


Try the driver from here:

Canon Print Filter for Linux

An old suse how to:

Hopefully still applicable.

After installation, you should find the printer model in the list.

If you need further help with this, post the details describing where you’re getting stuck.

Thanks Deano,
I’ll give it a try this PM.

You could also try out Gutenprint. That’s what I use. It has lots of printers that are supported. Search Results
Go for the 5.2.4 version. The latest version is up to 5.2.5 but you’ll have to install that from source (if you know how to do it) because an .rpm has not been written for that one yet :frowning: .

I tried that to no go. It wants dependancies that are old. I guess it doesn’t like the newer versions, ie; libpng10 and libxml. they are already installed but they are newer versions. the rpms will not install wanting the older versions.

I’ll now try gymnarts idea.

ok, I installed Gutenprint. now what do I do?

If the ip1500 model is not listed as an option, (although I would have thought it would be included), I have seen suggestions (on old threads) to try the gutenprint BJC-7000 driver, or try a similar ip**00 series driver.

Make sure your printer is connected and turned on. You can configure your printer via the CUPS web interface (using your favorite browser):


Click on ‘Add Printer’. Follow the prompts given, including the selection of an appropriate gutenprint driver.

deano, again thanks. ip1500 is not listed in yast/printer. It starts with ip2000. I tried a few in the list, but none would work. So I went to CUPS added several but they didn’t work either.

Again, Thanks, I think I’ll give up for now.


Some Canon models are only good for paperweights unfortunately. I don’t want to lead you on a wild goose chase, but this convoluted Ubuntu thread had one poster suggesting that the ip4100 driver was ok with their ip1500 printer. Did you try that one (amongst the others)?

If you’re willing to pay for a driver (which I admit I wouldn’t be), you can always use a driver from Turboprint. The Canon_PIXMA_iP1500 is one of many supported models.

Sorry I couldn’t assist further.

Well, I installed TurboPrint (as a 30 day trial) and it did work. But I don’t think I’ll pop for the cost, and keep trying the Suse way,

This may not take you any further forward, but this site Canon Europe - PIXMA Linux Support Pageoffers some info. I use a IP3300 and IP 2500, and they both work under 11.2. But, sorry, I do not have access to them at this time (I have just moved back from Europe and all my stuff is in storage), nor the computer they are/would be connected to. I recall that I had problems with dependencies as well but, I tried to install found what was missing from fault messages, searched for - found - downloaded and installed RPMs required, and all was well. You should be able to do the same for, eg libxml-1.8.17-11.i386.rpm. This the actual RPM I have installed to give me the dependency, and it works fine. Don’t give up on the Canon drivers as, if you can get them installed, they work well. Try putting the whole name into Google, there are loads of sites that have this file.