How to force bootloading the slave? HELP!


I have two HDDs, the master has Windows XP and all important data, on the slave I installed openSUSE. For various security reasons I’m forced to encrypt the Master using CompuSec software. This program encrypts MBR and replaces it with itself. I knew about it before installing SUSE, so I forced installer to place GRUB in dev/sdb2/boot(slave) instead in MBR of sda(master). The slave is removable disk. The idea was to force booting from slave before the master using BIOS configuration, so when I remove the slave, master would boot and ask for decryption key. The master and slave use separate cables.

I configured BIOS in this manner:

First Boot Device: Floppy
Second Boot Device: CDROM
Third Boot Device: HDD-1
Boot Other Devices: True

It’s not working. Whatever I set as third device(I could choose from HDD-0 to HDD-3, and many other things, like USB, SCSI and ZIP drives) it’s not working.

Could you tell me, what I did wrong and what should I do?

Having the grub installed to sda2 is fine and you must set that drive as first boot in bios. But you need grub on it’s MBR.

If you installed with the dvd you can boot from that and repair grub. Make sure it goes to MBR of sda2. Check everything carefully.

Then, yes. You can remove that drive switch boot in bios back to sda1. and all will be fine.

N.B* If you installed from the cd. You will have to do the install again to get grub in the right place.
If you didn’t already do it. Make sure you set a mount point during the partitioner to have your windows partition mounted
You could use
you have to manually type this in as default mount points are unix based
All it does really is place a folder in your tree /windows
You could call it whatever you like.
Partitioning/Install Guide - openSUSE Forums

I’m sure someone else will have a better idea, but for now I would suggest you create a boot floppy. This assumes your system will actually try to boot from a floppy, and that you can get your hands on a good, blank floppy disk. Elsewhere on the forum, I found this link: How to install the bootloader an a floppy disk? - openSUSE Forums . Follow the instructions given by mingus725.

caf4926 posted while I was typing. My answer would only work once you booted into Linux. Another option that occurs to me is Smart Boot Manager – smart boot manager . Better than floppies is a custom boot CD, but the HOWTO on this site is obsolete, and I’m not up on how it works any more.


Thank you all for your help. Unfortunately I can’t do either of your suggestions. I think I’ll just manually witch booting order by changing places of IDE cables and switching master to slave, and slave to master. Then I’ll reinstall SUSE making sure that it will write GRUB to the removable disk MBR.

Caf4926, anything I place on any of sda partitions or MBR will be encrypted. The goal here is to make sda unaccessible and hidden, so the only way to access it would be to remove sdb with SUSE and then boot sda, enter passkey and use Windows. The CompuSec software is loading on boot from MBR, asks forr passkey and then is loading the actual MBR, which was also encrypted. This way even keylogger placed in MBR won’t be able to log the passkey. This also means that I can’t place GRUB here, because I would be forced to decrypt disk before loading SUSE. CompuSec works i the background between HDD and OS, so when correct passkey is entered on boot, the disk is decrypted sector-by-sector during any read operation, and encrypted in the same way during any write operation. Without passkey whole disk looks like it’s messed-up and filed with random bytes. This way even NSA can’t read it(encrypted with AES-256).

If both of these drives are IDE and each is on its own cable - and therefore connected separately on two different motherboard channels - then there is no slave; both are masters. Master/slave only exists when two IDE drives share the same channel. Check the jumpers; both must be set to master or, if your cable/board supports “cable select”, that will work also. This could explain why the second drive is not booting despite the bios configuration.

Or the issue could be that the drive is “removable”. Is there a separate disk controller for this drive? The bios hdd options may only apply to drives hung off the chipset controller. With many bios’s, especially older ones, a separate controller, even if an on-board discrete device, is not recognized for boot.

Finally, look in the bios for any configuration specific to that drive’s controller. Sometimes the controller type needs to be toggled to be available for boot, or the drive geometry access method (Large, LBA) needs to be changed for the drive to be accessible.


The primary master is HDD with Windows, the secondary master is CD-ROM and the secondary slave is other HDD with SUSE. For some mysterious reason BIOS boots from first HDD available, no matter what I set in booting sequence. BIOS recognizes both HDDs, but it won’t do as I want. So I’ll connect CD-ROM and second HDD to first IDE channel, and then the Windows HDD to second channel. It’ll take me less time than playing with BIOS.

Two years ago I had major problem with motherboard. Some capacitor blew up in PCI cards power distribution and management area. After that I have permanently damaged the IC, which holds copy(ghost) of BIOS. I get PXE-E005 EEPROM checksum error. It’s no affecting normal operation, but I think it could affect the booting sequence, especially, if it’s not the logical one.

Anyway, thank you for your help and advices…


I switched IDE cables and everything works fine.