How to force boot into "safe mode"?

After sucessfully installing Suse I changed my screen resolution to YUV 60Hz @ 480p (mode 2)so I could easily read the font. I could now read the font just fine but everything was too big to fit in the small resolution. So I changed it to YUV 60Hz @ 720p (mode 3) Now everything was a proper size but I could no longer read the font. So I tried changing it to YUV 50Hz @ 720p (mode 8) to see if that would clear up the font a bit. In changing the resolution I found out that mode 8 does not work with my TV. How can I swap back to mode 2? So I can try to make the Fonts larger before going back to mode 3?

I originally changed the settings in the kboot.conf using kwrite. But now after turning on the ps3 I am greeted by my bootloader with the option to boot either suse or “game os” but there is no “safe mode”. So I boot into suse. I get a welcome screen then my screen goes blue, & after a short while I hear the logon sound playing.

How can I get my video back?

I can’t help with your question, but I do strongly suggest you ask the moderator to move your thread to the hardware sub-forum. Those who hang out in Install/Boot focus on different kinds of problems, and yours requires special expertise as it deals with TV and PS/2. I also suggest a title which fits the problem; the current title refers to a standard selection on the boot menu and has nothing to do with your problem. Good luck.

Thank you for your reply.

I fixed the issue. I could barely make out some small text at the bottom of my screen, I went to a buddies house for a clearer look at the boot screen and thats how I figured out how simple my problem was to fix. If anyone else encounters this issue. Simply press “1” on your keyboard while in the boot loader to load into safe mode. Then once you are in safe mode you should be able to make permanent changes to your resolution by simply editing your /etc/kboot.conf file with the proper mode.

Heres an example of mode 4 which is 1080i YUV @ 60Hz

openSuSE="/dev/ps3da5:/vmlinux initrd=/dev/ps3da5:/initrd quiet panic=42 sysrq=1 video=ps3fb:mode:4"

refer to this link to see all the different options available regarding video modes on the PS3 and how to properly set them up.

!EDIT! whoops I got my distros mixed up! fixed now.