How to force boot from Raid Controler not USB drives

I have installed the OpenSuse 11.4 on a Dell PowerEdge sever with a small mirrored drive. I also have 2 external USB drives I want to stay connected for use as backup disks. When I leave the USB drives plugged in during boot up Suse tries to boot to them and stops. If I unplug them then SuSE boots correctly.

I looked in BIOS and there isnt even a boot USB device in the boot order just CD/Hard Disk and Floppy.

Just wondering if theres a way to force boot to the raid controller then USB drives in a specific order.

Thanks in advance,

Hi !

Usually, Linux boot loaders (like GRUB) won’t boot from USB devices just because they’re plugged at boot.

Your BIOS may do this, if it regards your USB devices as CDs (or DVDs) - you didn’t yet give details about the contents
on your USB drives.

Good luck

The USB drives were formatted with (6) 300GB ext3 partitions.

Thanks for the reply,

What I wanted to make sure is that you didn’t transfer the contents of a CD or DVD image to your USB devices
(which may have been USB sticks of a few GB).

I just guess that you didn’t do this (I have to guess, since you still don’t give that many details about the contents
of your USB drives).

I have an ASUS motherboard which offers the possibility to choose between booting from different physical devices
even graphically, showing symbols for CDs, USBs, HDDs, and letting me change the boot order by drag and drop.

This may or will not be the same in your case.

But you should check your BIOS settings again for preferences regarding the boot order
from different physical devices, like USB devices.

Good luck

Many BIOSes will have one setting where you can specify boot order among CD / Hard Drive / Floppy, and then another separate setting where you specify the priority order of hard drives, so that it will try to boot from the first one. I don’t remember if PowerEdge BIOSes are organized that way. There may also be a “Boot other devices” option which you can set to Off or Disabled.

And not that this is likely to fix anything, but any reason you can’t put on the latest openSUSE 13.1 while you’re at it?