How to Fix oxygen-gtk theme on GTK+ 3 Applications on OpenSUSE 12.1

after a bit of digging i learned that OpenSUSE 12.1 did not ship with the GTK 3 version of oxygen gtk3 below is how to install.

Step one ass the swyear repo.

sudo zypper ar Index of /repositories/home:/swyear/openSUSE_12.1

step two install oxygen-gtk3

sudo zypper install oxygen-gtk3

step three

use your favorate text editor to edit /etc/gtk-3.0/settings.ini

add this line

set gtk-theme-name = oxygen-gtk

while this is not a Perfect solution (icons are not Changed) it’s better than it was

i cant see to edit my post but the full URL for the repo is http://download.opensuse.org/repositories/home:/swyear/openSUSE_12.1/

for system setting:
edit /etc/gtk-3.0/settings.ini
for user setting:
edit ~/.config/gtk-3.0/settings.ini

[Settings]
gtk-theme-name = oxygen-gtk

Note:
you can get these code with

git clone -b gtk3 git://anongit.kde.org/oxygen-gtk

seem developing still,
if you found any bug, all I can do is update to the latest code. use at your own risk

Thanks for this helped me when setting the themes for my Groupwise Client.

Cheers
William