How to fix error CUDA install Leap 15.2

Hello everyone,

I have been battling with CUDA toolkit and i cannot for the life of me install it. the further i got is here, with this message:

Problem: cuda-11.1.1-1.x86_64 requires cuda-11-1 >= 11.1.1, but this requirement cannot be provided
  not installable providers: cuda-11-1-11.1.1-1.x86_64[cuda-opensuse15-x86_64]
 Solution 1: Following actions will be done:
  deinstallation of nvidia-computeG05-450.80.02-lp152.37.1.x86_64
  deinstallation of x11-video-nvidiaG05-450.80.02-lp152.37.1.x86_64
  deinstallation of nvidia-gfxG05-kmp-default-450.80.02_k5.3.18_lp152.19-lp152.37.1.x86_64
  deinstallation of nvidia-glG05-450.80.02-lp152.37.1.x86_64
 Solution 2: do not install cuda-11.1.1-1.x86_64
 Solution 3: break cuda-11.1.1-1.x86_64 by ignoring some of its dependencies 

I know this one probably doesn’t work, as it is 11.1 and it requires 455 drivers, however I tried, 4 previous versions of CUDA and they all yield exactly same messages…
What do I do now?

btw GPU is GTX 1660 Ti

Hi
I always install the latest Nvidia blob, as well as the manual install of cuda and skip the driver install… eg hardway, requires extra work on a kernel update…

Thank you for your replay.
I am translating what you wrote here… Newbie here…
I have installed newest nvidia drivers that the repo offers, no 455 there just yet
the rest you said, I dont know, i tried downloading rpm and running that, but that gave me the error above.
tried .run files, but that was installing everything bar 455 driver and didnt work overall…

I tried upgrading kernel as apparently that is needed however it doesn’t work either…

@localhost:~$ sudo zypper install kernel-5.3.18-lp152.50-dev=default
[sudo] password for root: 
Loading repository data...
Reading installed packages...
'kernel-5.3.18-lp152.50-dev=default' not found in package names. Trying capabilities.
No provider of 'kernel-5.3.18-lp152.50-dev=default' found.
Resolving package dependencies...

Nothing to do.

Hi
Have a read here: https://en.opensuse.org/SDB:NVIDIA_the_hard_way