How to fix broken Yast?

Hi. After a package download process was quitted unexpectedly on my opensuse 11.1 installation

(read the full story here: Help! Can’t launch kwin! [OMG] - openSUSE Forums)

I can’t get Yast to work. Neither GUI YaST2, nor commandline YaST. When I click on a package to update it, YaST hangs. (There are two spinning balls near to the cursor, and nothing happens)

I tried a forced reinstall of all my yast packages which I have installed via zypper, but still no luck.

Any ideas, or do I need to reformat? Thanks in advance!

PS.: It doesn’t work for other users neither.

Looks like your RPM database is corrupt. Try this:
Open a terminal window and do:
~/>su -c ‘rpm --rebuilddb’
Enter your rootpassword when prompted for.

This will take a while. As the statement says it rebuilds the RPM package database. The ‘su -c’ executes is with root-privileges.

Good luck, let us know how you got on.

Have you tried Yast from level 3

At the grub boot screen, pause the boot by moving the down arrow
Now move it back to the default boot and press Backspace until all the kernel boot arguments are gone. Now just type the number: 3
Hit enter

At the CLI login, login as user with username and pass
Then type su (enter) and then the root password
Hit enter a couple of times

Now type: yast

If it works, it will start a basic yast navigated by keyboard.
Filter by repo and select ‘System’
Then choose to Update All in this list Unconditionally

I downloaded & installed all the packages (5.5 GB packages, any with 1Mb/s internet it isn’t that easy!) And still no luck. Yast2 hangs when trying to update libqt4.
It may seem strange, but I tried removing/installing with kde4-kipi-plugins package and it works perfectly.

Is reformatting the only cure ? :frowning:

I downloaded & installed all the packages (5.5 GB packages, any with 1Mb/s internet it isn’t that easy!) And still no luck. Yast2 hangs when trying to update libqt4.
It may seem strange, but I tried removing/installing with kde4-kipi-plugins package and it works perfectly.

Is reformatting the only cure ? :frowning:

PS.: When I try to update libqt4 to 4.5.2 via zypper, it says a lot of kde4 packages need to change architecture from x86_64 to i586. Maybe YaST2 works ok, but I just didn’t have time to let it ‘think’ about the dependencies? (I mean, it needs much more time than zypper to find all the dependencies)

PS.: I am sorry about partial double-post, but I can only edit messages until 10 mins they have been posted.

download the libqt4 package in question manually via your web browser
then do from a su terminal:

rpm -Uhv *package_name --force

remember the TAB button will auto complete after you type a couple of the letters of the package name

warnec@linux-mrpe:~/Pobrane> rpm -Uhv libqt4-4.5.1+ --force
błąd: Niespełnione zależności:
        libqt4 = 4.4.3 jest wymagany przez (zainstalowany) libqt4-sql-4.4.3-4.8.2.x86_64
        libqt4 = 4.4.3 jest wymagany przez (zainstalowany) libqt4-qt3support-4.4.3-4.8.2.x86_64
        libqt4 = 4.4.3 jest wymagany przez (zainstalowany) libqca2-2.0.1-10.2.x86_64
        libqt4 = 4.4.3 jest wymagany przez (zainstalowany) qt4-qtscript-0.1.0-3.1.x86_64
        libqt4 = 4.4.3 jest wymagany przez (zainstalowany) libqt4-x11-4.4.3-4.8.2.x86_64
        libqt4 = 4.4.3 jest wymagany przez (zainstalowany) libqt4-devel-4.4.3-4.8.2.x86_64

błąd = error
Niespełnione zależności = Unsatisfied dependencies
jest wymagany przez = is required by
zainstalowany = installed

PS.: Maybe I should try to force installing of this package via zypper? Zypper seems to be working (I mean, it doesn’t hang like YaST2).

BTW, why to the libqt4 dependencies make me change architecture of most of my packages from 64-bit to 32-bit? I don;t get it. Why should it be needed?

If I recall correctly you have been messing with QT repo’s
Help! Can’t launch kwin! [OMG] - openSUSE Forums
I advised you against QT45 and you said:

I’m sorry to say that, but I don’t care :wink: So far qt45 proved (at least for me) to display GUI without any errors

How about posting your repo’s

zypper lr --details

Ok, but I don’t think it’s my fault (I mean, my selection of repos)
Before the update to 4.3b2, it all worked correctly. But here you go:

warnec@linux-mrpe:~> zypper lr --details
#  | Alias                        | Nazwa                                          | Włączono | Odśwież | Priorytet | Typ    | Adres URL                                                                            | Serwer                                                           
1  | 11.1 - VideoLan              | 11.1 - VideoLan                                | Tak      | Tak     |   99      | rpm-md |                             |                                                                  
2  | Anubisg1                     | Anubisg1                                       | Tak      | Tak     |   96      | rpm-md |               |                                                                  
3  | KDE_4.2                      | KDE 4.2                                        | Tak      | Tak     |   80      | rpm-md |                     |                                                                  
4  | KDE_4.2_-_Community          | KDE 4.2 - Community                            | Tak      | Tak     |   80      | rpm-md | |                                                                  
5  | KDE_Qt45                     | Qt 4.5.x development snapshots (openSUSE_11.1) | Tak      | Tak     |   75      | rpm-md |                   |                                                                  
6  | Kadu_repository              | Kadu repository                                | Tak      | Tak     |   99      | rpm-md |               |                                                                  
7  | Libdvdcss repository         | Libdvdcss repository                           | Tak      | Tak     |   99      | rpm-md |                                                    |                                                                  
8  | X11:XGL-KDE4_Factory         | X11-XGL Factory                                | Tak      | Tak     |   70      | rpm-md |      |                                                                  
9  | devel_translation            | Tools for translators (openSUSE_11.1)          | Tak      | Tak     |   99      | rpm-md |          |                                                                  
10 | openSUSE 11.1-0              | openSUSE 11.1-0                                | Nie      | Nie     |   99      | yast2  | cd:///?devices=/dev/sr0                                                              |                                                                  
11 | openSUSE-11.1-Java_1         | openSUSE-11.1-Java                             | Tak      | Tak     |   99      | rpm-md |            |                                                                  
12 | |                   | Tak      | Tak     |   99      | rpm-md |      |                                                                  
13 | openSUSE-11.1-Packman        | openSUSE-11.1-Packman                          | Tak      | Tak     |   95      | rpm-md |                                       |                                                                  
14 | openSUSE-11.1-Updates        | openSUSE-11.1-Updates                          | Tak      | Tak     |   99      | rpm-md |                                             |                                                                  
15 | openSUSE-11.1-Wine           | openSUSE-11.1-Wine                             | Tak      | Tak     |   99      | rpm-md |             |                                                                  
16 | openSUSE11-1-sdlmame         | openSUSE11-1-sdlmame                           | Tak      | Tak     |   99      | rpm-md |                |                                                                  
17 | openSUSE:11.1                | openSUSE:11.1                                  | Tak      | Tak     |   97      | yast2  |                             |                                                                  
18 | openSUSE:11.1:Update         | openSUSE:11.1:Update                           | Tak      | Tak     |   97      | rpm-md |                                            |
19 | openSUSE_11.1-Kernel         | openSUSE 11.1-Kernel                           | Tak      | Tak     |   99      | rpm-md |           |
20 | openSUSE_11.1-Nvidia         | openSUSE 11.1-Nvidia                           | Tak      | Tak     |   97      | rpm-md |                                            |
21 | repo-debug                   | openSUSE-11.1-Debug                            | Nie      | Nie     |  100      | NONE   |                       |
22 | repo-non-oss                 | openSUSE-11.1-Non-Oss                          | Tak      | Tak     |  100      | yast2  |                         |
23 | repo-oss                     | openSUSE-11.1-Oss                              | Tak      | Tak     |  100      | yast2  |                             |
24 | repo-source                  | openSUSE-11.1-Source                           | Nie      | Nie     |  100      | NONE   |                      |
25 | repo-update                  | openSUSE-11.1-Update                           | Tak      | Tak     |  100      | rpm-md |                                            |

yes = tak
włączono = enabled
typ = type
priorytet = priority
odśwież = refresh
adres = adress
nazwa = name’

PS.: I know I don’t need the ‘Kernel’ repository, I was just too lazy to remove it until now :wink:

I wonder how many other things have been forced.

forced = broken

I would run a zypper verify
Though with that many ridiculous repositories being used. I would hope you knew how to undo the mess you create.

I think you need to step back a bit and just run OSS, Non-oss, Packman and update for a little while maybe keep your 42 and nvidia.

There is many repos I’m dubious about. You even have kernel higher than update, you can’t expect people to support you when you have things like this.

OK, I wrote about the fact that adding kernel repository was in fact my big mistake - I reliazed it just after I added it, and disabled it. But I never removed it, because I was too lazy :wink:

And what’s so wrong, exactly? Can you tell me? I can’t find anything which would make the system unstable.

PS.: OOps, now that I look into it, it looks like I didn’t disable it, and left it enabled :stuck_out_tongue: I hope I can do something with this. If not, I’ll just reformat the whole system. As I said before, it ran without any problems before update to 4.3b2, so I think that after reinstalling it will work OK as it did before. Just hoped there is an easy solution without reformatting.

Never you mind. I’ll just reinstall the whole system tommorow. I’m used to breaking a whole system by making some kind of silly mistake - that’s how I learn Linux :wink: I’d just like to know what I did wrong regarding the repo management. I am almost entirely sure I need all of those, except kernel repository, but I did not download and/or install and packages from there.

Firstly qt has been a few peoples bugs search bugzilla.

I for one don’t now whether you actually have a supported kernel or one that is in testing. Even then it is vanilla, yes I doubt probably the cause of your qt problem going on bugzilla I would suspect qt. Though perhaps it is the kernel have you checked what kernel you are running is it the one from update vanilla has no suse patching?

Then you’ve not read the multimedia thread there should be no need to have vlc or even libdvdcss still, and are normal suspects for problems with multimedia.

Java I haven’t got a clue but some things work better with some java implementations over others. I see no need for anubisg1’s repo if going on the brief look I saw from suse pages he has become a packman packager therefore they should be available on there.

OK I’m bored now and continue with etc etc etc… how about you justify why you need them. I really can’t see that many people need the extra point releases they will get by enabling this and that repo. People should enable repo’s because they need them and understand what the repos provide.

Just stick with a basic level of repo’s. I suggest the kde42’ repos, and no extra QT