how to fix an error when updating via the "update software"?

how to fix an error when updating via the “update software”?
Method “SetHints” with signature “as” on interface “org.freedesktop.PackageKit.Transaction” doesn’t exist

You did not mention your openSUSE version or your Desktop that is being used. The Desktop in particular effects how you might over come this problem. If we can assume you use KDE then try …

  1. YaST (Enter Root Password) / Software / Software Management
  2. Options / Allow Vendor Change (check)
  3. Package / All Packages / Update If Newer Version Available

If there are any conflicts and there is an option to Not install the conflicting program, then do that. Otherwise here is my general advise is to avoid package problems, the most important thing to do is to: NEVER ignore a dependency, even if YaST/zypper/updater gives you such an option! In general, never switch to an >inferior< architecture and the solution is most often to just switch Vendor to the >Packman< repository. So changing the vendor is OK, but >ignoring< dependencies is never a very good idea!

Thank You,

Open SuSE 12.1
Gnome 3

As you can see, you must include just what software versions you need to upgrade. So, here is a modified instruction set for Gnome:

  1. Activities / Applications / System Tools
  2. YaST (Enter Root Password) / Software / Software Management
  3. Options / Allow Vendor Change (check)
  4. Select Upgrades with mouse on bottom Left
  5. Press Upgrade Button on bottom right under the Package Listing window
  6. Pick don’t install for any conflicts
  7. Press Apply on bottom right corner.

If there are any conflicts and there is an option to Not install the conflicting program, then do that. Otherwise here is my general advise is to avoid package problems, the most important thing to do is to: NEVER ignore a dependency, even if YaST/zypper/updater gives you such an option! In general, never switch to an >inferior< architecture and the solution is most often to just switch Vendor to the >Packman< repository. So changing the vendor is OK, but >ignoring< dependencies is never a very good idea!

Thank You,

Now he writes.

Message did not receive a reply (timeout by message bus)

Sorry, but that short reply will get no more help because it make no sense to me. Need more information as to any additional errors you may be getting.

Thank You,

On 2012-01-11 22:36, b1999417 wrote:
>
> Now he writes.
>
> Message did not receive a reply (timeout by message bus)

Who is “he”? What were you doing?

Full details. Write it, the keyboard will not bite at you.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)