How to Find UUID of USB External Hard Drive or Android phone?

I haven’t bought a USB external HDD, so I am testing with my USB Android Phone. I can’t find my phone at all except in Dolphin with the full path of mtp:>LG-M322. I have tried sudo blkid and sudo fdisk and cd /dev/disk/by-uuid with an ll. All I could find is the file systems listed in fstab. If I hook up an external HDD, will I be able to see it with blkid? Also, is there ANY way to find my phone in the command line?

Thanks so much for any help!!!

I ahven’t no experience which sucj devices, but when some software can use it as mtp:>LG-M322, then I assume it is not mounted as a file system on a mass-storage device, but that some other protocol is used.

The fact that it is not detected as mass storage and thus has no device files confrms this.

You could (as root) use

dmesg -w

and then connect the device and see what entries are added to get more information about what happens.
(stop the dmesg with Ctrl-C).

I tried it and got lots of information about my phone, BUT, there is no UUID in the information. Do you happen to know the mount point for mtp:>LG-M322? Thanks!!!

Well, saying “ther is a lot of information …” without showing anything does not enable anybody to make comments.

And as I tried to explain, when there is nowhere the words"mass-storage" in that output, is is not seen as mass-storage, and thus there are no /dev/sd…, nor /dev/desk/by… device files created and thus there is nothing to mount. And thus there is no mount point used.

It apparently uses some protocol to communicate with the phone. But it is not mounted (added to the directory tree).
And that protocols you see from the mtp. Thus MTP, see

It could however be that you can switch your phone from MTP to Mass-storage. LIke many cameras can switch from PTP to Mass-storage.

BTW I have no idea what this first remark has to do with the phone.

Nor do I understand fully why you want to know about how the phone is connected (except curiousity) when you can use it through Dolphin.

There does NOT seem to be a Mass-storage option on my phone as I do not have a secondary microSD card in it. I will check out the link you provided. Please don’t spend any more time on this. I thank you for all your help!