How to enable persistent logs?

My laptop froze upon boot (after resume from hibernate) on Leap, and I had to force poweroff. I couldnt find any logs for the previous boot:

localhost:/var/log # journalctl -b -1
Specifying boot ID or boot offset has no effect, no persistent journal was found.

How can I enable this ?

@aurabindo Hi, edit the /etc/systemd/journald.conf and change Storage=auto to Storage=persistent

Ref: man journald.conf :wink:

2 Likes

Thank you very much for the quick response!

There’s another way without editing any .conf file, as it is set to auto. Instead, create the folder and set its permissions.
Instructions are here.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.