How to enable nvidia drivers for GTX1080?

xrandr output:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 3840 x 2160, current 3840 x 2160, maximum 3840 x 2160
default connected primary 3840x2160+0+0 0mm x 0mm
    3840x2160      88.00*

It works!
And it was very stupid.

The default setting in windows is that the Intel card is used, but when 3D is required by an app the NVIDIA kicks in. And to be honest, the performance, even in windows is utterly ****. Pushing Fn+F7 turns on the NVIDIA. It’s a BIOS setting, so persistant. I had to re-install windows to make this settings, then removed windows and re-installed Linux again. It’s working ever since. Fn+F7 isn’t working on Linux.

I tried to find the same settings in the BIOS, but I can’t find it. I know previous models have it.

Anyway it works and performance is amazing. Finally I can multi-box EVE-ONLINE :cool:

Also, when I was in windows, I used a tool to create an EDID file from the monitor to load in Linux, because somehow Linux doesn’t the monitors info. Using the EDID gives you more resolutions other then just the default one.

Thanks for the help!