How to enable Multiple cores in openSuse 11.4

Hi,

I am newbie to linux and recently installed the openSuse on my desktop. My desktop has an AMD processor with 4 cores.

After installing, I found that it was getting stuck while booting at ‘starting udev’ something. I searched through the forums and found that by using the boot option, maxcpus=0, I could successfully boot. But, for any other value for ‘maxcpus’ other than 0, does not work.

As far as I know, the above boot option disables SMP, right? Then, how do I make use of the remaining 3 cores? I don’t know if this question is dumb or something. So please tolerate with it…

Any help would be appreciated. Thanks in advance! :slight_smile:

Hello pramodhkp,

Welcome to these Forums.

You are at the right place in the forums to ask this and IMHO your question is not dumb at all.

While I do not know the ultimate answer, it is obvious that only one core will be used when you ask for it with* maxcpus=0*. I guess we have to try to find out what your original problem is and find if a less damaging solution for this. I once had a similar problem and in the end it was a bug in the kernel. Thus be patient, because we have to wait for people with more knowledge about these things then you and me.

In he mean time, to gather some more info, when you boot in Failsave option, what happens then?

Check your BIOS settings and see if you can have and of the following
ACPI APIC support to ENABLED - ACPI 2.0 Support to ENABLED.

On 2011-11-01 11:46, pramodhkp wrote:
>
> Hi,
>
> I am newbie to linux and recently installed the openSuse on my desktop.
> My desktop has an AMD processor with 4 cores.
>
> After installing, I found that it was getting stuck while booting at
> ‘starting udev’ something. I searched through the forums and found that
> by using the boot option, maxcpus=0, I could successfully boot. But, for
> any other value for ‘maxcpus’ other than 0, does not work.
>
> As far as I know, the above boot option disables SMP, right? Then, how
> do I make use of the remaining 3 cores?

You can not.

Try to boot in normal boot. You say it will not work, right. Then boot with
your option, and look at /var/log/boot.omsg. You can paste it here between
code tags - advanced editor, #. If you do not know what codetags is, do not
post. You can also use a pastebin.

This way we can have a look at why it failed to boot in normal mode.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

and for the CODE tags, here is the Howto: Posting in Code Tags - A Guide

So, I tried booting in normal mode… didn’t work… Here is the boot.omsg file.

linux boot.omsg - Pastebin.com

Also, an other problem has surfaced… the system just logs off to the log in screen sometimes…

On 2011-11-03 14:16, pramodhkp wrote:
>
> So, I tried booting in normal mode… didn’t work… Here is the
> boot.omsg file.
>
> ‘linux boot.omsg - Pastebin.com’ (http://pastebin.com/3YupYRWn)

It looks as if the system enter halt as soon as it starts. No reason given.
Unless it is you stopping it. No errors or warnings.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I have a same problem. My solution was downgrade to 11.3.

Try editing /etc/sysconfig/boot so that:

## Type:        yesno
## Default:     yes
#
# Run all scripts or rather start/stop all services
# which are independent from each other in parallel.
#
RUN_PARALLEL="no"

You can use any text editor or “YaST > System > /etc/sysconfig Editor”

I wouldn’t call that a solution. It is a by-pass at the maximum.
When you do not do anything about it like discussing it here and then, when the general consensus is that it is a bug, reporting it as a bug, it will be their for years to come (except when somebody else does the reporting).

I had the very same problem on my fathers machine.
I got rid of it deactivating a precise BIOS option in the ACPI selections. The unfortunate thing is that I do not have currently access to that machine to give you the solution. But it was the same thing (got stuck, needed “Run parallel = no”. The machine was sluggish and slow. After deactivating this state (I recall it was an energy saving state of the CPU) the system turned lightning fast and fully functional. All boot problems disappeared. Hope that helps. (I recall vaguely it was called “C2 state activate = yes” on a Gygabite mainboard. I “belief” Award BIOS. Try whether this C2 state is activated in the BIOS and try to deactivate. And if this is not the case, try to google for your “mainboardtype phaenom linux problem”. You may find well the solution, I tend to belief it will not be a openSUSE but a BIOS bug. Have a look also if you have the latest bios installed for your revision.

@OP: Is this a 32 or 64bit install ? Try booting from a 64bit LiveCD and see if the problem persists.