How to enable color profiles?

Leap 15.4 kde. I have a color profile for my monitor, it’s installed and I can’t seem to enable it.

I have tried both enable system wide by giving the root password or just for my login and somehow it doesn’t work.

I’d like to disable the default LG: WFHD and use the other one: WFHD #1. What am I missing or doing wrong?


Here on Leap 15.3 but, without checking my Leap 15.4 system, it’s probably the same for the newer KDE Plasma.

  • Here with a Iiyama ProLite XB3288UHSU – Colour Profile: PL3288UH.

 > l /usr/local/share/color/icc/
insgesamt 20
drwxr-xr-x 2 root root 4096 31. Aug 2020  ./
drwxr-xr-x 3 root root 4096 31. Aug 2020  ../
-rw-r--r-- 1 root root 8412  7. Jul 2019  PL3288UH.icm

If you move over to the “Profiles” tab of the KDE Plasma Color Corrections, you’ll find a Screen Profile, in your case, possibly named “WFHD” – in the “Information” tab of both the “Devices” and “Profiles” tabs, you may find a “.icc” file name with the prefix “edid-”.

  • In my case it’s “edid-1676af105055b401b4552e95d48bbe1a.icc
    ” …This file is located in ‘~/.local/share/icc/’ …

Otherwise, the “Information” tab may display the file name of the Profile located in ‘/usr/local/share/color/icc/’ …

Regardless of what Colour Profiles have been found by KDE Plasma, simply check the Check-Box of the Profile labeled “Default” and, that’s it!

Don’t know what happened, but this morning the 2nd item is enabled and the 1st, the default is not. So my problem is solved, but I don’t know why.

Yesterday, there were some updates but mainly related to glibc, not to kde/plasma.



With one of my users, I had an issue with multiple versions of the ‘edid-???.icc’ file located in ‘~/.local/share/icc/’ –

  • After removing the above mentioned ‘~/.local/share/icc/’ files, I logged out, logged back in and checked – KDE Plasma had placed a new version of the ‘edid-???.icc’ file in ‘~/.local/share/icc/’ but –
    The settings in the KDE Plasma “System Settings” couldn’t be changed until –
    *=2]I logged out and, logged back in again …

Bottom line – you have to log out and log back in again – twice – … >:)

Like you said: I did restart twice and now it works!


And, that’s exactly the recipe everyone needs …

  • Maybe, I’ll raise a KDE Bug Report to have the behaviour changed but, I suspect that, it’s something Colour Management has to live with – therefore the recipe …

I’ve raised the KDE Bug Report 456941 – “Selecting a Color Profile for a Device not immediately activated”