how to enable bluetooth?

Hi guys,

I’ve OpenSUSE 12.2, KDE 4.9 running on my laptop Dell Vostro 1520. I saw a bluetooth icon on system tray, but when I click on that icon, it show me “No adapters found”. And also, the led bluetooth is not working.

Thanks for your helps!

Bluetooth works fine for me in 12.2 (KDE 4.8.5), and I did not have to do anything special for that. Possibly your hardware is not being recognized - I’m not sure what you can do about that, other than wait till suitable drivers are available.

With 12.3 M2 (a beta release) and KDE 4.9, bluetooth does not work at all. I suppose I should have tried it in Gnome, to isolate whether it is a KDE only problem.

i could easily connect to an external phone using a bluetooth dongle on GNOME 3.4.2 / openSUSE 12.2
I was really simple with no hassle at all.

“No adapters found”

Can you check whether the hardware is getting displayed in YaST==>Hardware Information ?

I think we need “bluedevil” to be installed on KDE for working with bluetooth

I tried dmesg | egrep “bluetooth”, but it show nothing
I installed bluedevil, that’s why I had a bluetooth icon in the system tray. But like I told, the led for bluetooth even not light.

I would install this package and check whether the device shows up

bluez-compat - Bluetooth Stack for LinuxThe Bluetooth stack for Linux. This package contains older and partly deprecated binaries that might still be needed for compatibility.

Can you check whether bluetooth is enabled in BIOS

Also check this post https://forums.opensuse.org/english/get-technical-help-here/hardware/451406-bluetooth-problems-3.html#post2269574

Is bluetooth activated via a switch or Fn key combination on this laptop? Next thing to check is

/usr/sbin/rfkill list
  • You may need to install rfkill first.
    For reference, I get
~> /usr/sbin/rfkill list
0: hp-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hp-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: hp-wwan: Wireless WAN
        Soft blocked: no
        Hard blocked: no
4: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
5: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

On 01/12/2013 06:06 AM, n00bvn wrote:
> Dell Vostro 1520

i googled that Dell and find that it is sold both with and without the
bluetooth add on “bt 360 module”
http://en.community.dell.com/support-forums/laptop/f/3518/t/19395969.aspx

that info causes me to wonder if that might be the root of the problem…


dd

This page states Vostro 1520 Laptop Details | Dell
Tech Specs tab

Connectivity 																																																																				


  - No Wireless N – 802.11b/g only
No Bluetooth®





Hi guys,

Thanks for all your helps!

I tried many thing but the bluetooth is still not working for me.
I installed bluez, I saw bluez-coldplug service running through Yast. I tried “rfkill list” but there’s no bluetooth. I tried “bluetoothd -u”, it said

D-Bus setup failed: Name already in use

I also checked on BIOS setup, no option for bluetooth.
Also again, when I focus the mouse on the bluetooth icon on system tray, it said “Bluetooth is Off”, and when I click left mouse on it, it said “No adapters found”. I still cannot turn the bluetooth led ON.

I also found this post How to turn on Bluetooth on Dell Vostro laptop [1320/1420/1520]? , it said that there’s no function key to enable bluetooth, in windows, they download the driver then bluetooth will be enabled. Cus’ I do not install windows on my laptop, so I cannot check this.

Thanks you guys again!

I’ve bluetooth led light, so I think there’s absolutely bluetooth function on my laptop.

On 2013-01-13 13:36, n00bvn wrote:
> I’ve bluetooth led light, so I think there’s absolutely bluetooth
> function on my laptop.

You can get a usb-bluetooth dongle very cheap and use it, probably out
of the box. Don’t fight your hardware, waste of time it seems.


Cheers/Saludos
Carlos E. R. (12.1 test at Minas-Anor)