how to eliminate recent files from rightclick on kwrite icon in the task manager

hi, on my laptop using 15.5 neon with KDE plasma 5.25.1 when I click on an icon of kwrite file in the task manager the menu propose me also recent files, how can I get rid of this behaviour??
I don’t like recent files is shown for any application, how can I get this?

This is a Plasma setting which is really easy to find:

Systemsettings -> Workspace -> Workspace behaviour -> Activities -> Privacy

Additionally there is a Kate specific setting. It’s also not hard to find. Open Kate and go to settings -> Session -> session elements

Manythanks, the systemsettings was already set to not remember opened documents but in kwrite (kwrite not kate) it doesn’t works, if I open a document it is remembered, and in kwrite settings I cannot find the same settings as in kate