How to downgrading to PulseAudio 3

Hi all,

I just upgraded my system to openSUSE 13.1 and some applications have some issues with PulseAudio 4. (Skype, flash video, to name a few). I didn’t have these issues with openSUSE 12.

Till the issues are fixed, I would like to downgrade to PulseAudio 3.0

Because I’m relatively new, I would appreciate some guidance to downgrade to PulseAudio 3.0 from the Terminal.

Thank you in advance.

You can get Skype to work with PA 4.0, see here:
PulseAudio 4.0 and Skype

The others should work just fine. What problems do you have exactly?

I can confirm the skype issue, but that piece of sh*t software already had issues on 12.3 too.
And I know from an on-line friend, lt has the same problem on mint.
It worked fine before ms got their hands on it. >:(

Flash video is working fine for me.

Thank you for the quick reply.

I’ve already modified the /usr/share/applications/skype.desktop file to read

Exec=env PULSE_LATENCY_MSEC=60 skype %U

But the issue still persists.

Actually, Skype is on the computer of my folks (retired and not that computer savvy) and they don’t launch it from the desktop. Skype auto starts automatically during system start.

The issue is that when my folks try to make a skype call, there’s a terrible audio buzz. And only a system reboot will stop the speakers from buzzing.

As for the other issue, when my folks were watching webTV (flash video) at one point the speakers started to buzz. (but perhaps that’s because Skype was running, I don’t know).

So I figured, if I will downgrade to PulseAudio the issues will be fixed.

That what you describe as a buzz sound is probably exactly the problem I am having.
I for now solved it by turning off all notification sounds.

Oh, and I forgot to mention: if you don’t use/need PulseAudio’s features, you can just turn it off in YaST->Hardware->Sound.
Just click on “Other” in the bottom-right corner and select “PulseAudio Configuration”.

This should fix all your problems.

And you’re **** right!!!

I disabled PulseAudio and Skype works, actually, better than before with openSUSE 12.3!!

Before I was using an external microphone with Skype as I couldn’t choose the USB camera mic source input in skype. I had only 1 option: PulseAudio.
Now that I disabled, I could pick the the USB Camera mic input!!!



Your suggestion to just disable PulseAudio is spot on! Thank you for that SUPER suggestion. One thing is for sure I can never suggest to uninstall Pulse to any user and I imagine downgrading would not be any better. Disabling PulseAudio is a valid choice. Keep up those good suggestions Wolf, you are doing very good! I have a blog post on PulseAudio that includes a link to my START bash script that includes the command to disable/enable Pulse so you don’t have to remember it.

PulseAudio and Selecting the Proper Sound Card Configuration - Blogs - openSUSE Forums

S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 1.11 - Blogs - openSUSE Forums

Thank You,

modifying that file didn’t work for me either.
What I did is just modify the shortcut entry in the kicker menu and it works just fine now (although notification sounds still don’t seems to work)

What do you mean with that?

Do you mean you don’t hear them at all? (if it’s just the login sound, that’s disabled by default in KDE 4.11, so that’s why you would not hear it :wink: )

Or do you get that “buzz sound” that was mentioned?

sorry, yes that is what I mean. I get no skype login sound when launching skype. But I also get no logout sound, no login failed sound.
I wasn’t aware these were controlled by KDE.

When I go into skype > options > notifications enable events is checked and clicking on test event I get no sound.
I get the same lack of sound when clicking on test event for all listed.

However, sound works fine for skype calls. I haven’t tested by having someone call me yet to see if I get a notification sound.

edit: oh, and I just tested going in to skype > options > sound devices
clicking on make a test sound produces nothing but clicking on make a test call then sound works just fine.

No, skype’s sounds are not controlled by KDE.

What I meant was KDE’s startup sound that was played in earlier versions when you logged in.
That’s disabled by default now, and there have been people thinking their sound is not working because of that.

Maybe those sound files cannot be played?
Do you have all multimedia codecs installed?
I don’t have skype installed, so don’t know which format those files have…

haha. Yes, I was aware that the KDE login sound is disabled by default in kde 11.xx
I was only referring to skype sounds. :slight_smile:

Yes, my system is all set re - multimedia setup and configuration.
Problem is solely in skype - but I don’t think it is surprising considering the flakiness of skype on linux over the past few years and the whole new kettle of fish with the new pulseaudio

Still on 12.3 and here I must force the play of a test sound to get skype to attach to the sound system. But s few time it did play itself.

today - miraculously my notification sounds are working.
I don’t know why, I haven’t adjusted anything.
I fully expect them to stop working again at some stage lol!

I would like to underline that one must be root to change the exec-command in /usr/share/applications/Skype

I thought that the change suggested didn’t work, but I changed nothing untill i made it using nautilus = as root user.

Now Skype sounds just work fine for me. (OpenSuse 13.1 - GNOME - 64bit on a Hp 630).

I hope this could help someone making the same “stupid” mistake.

Use the command “su”, enter your password, then start nautilus writing “nautilus” and browse to /usr/share/applications/ - Find Skype icon and then right click on it to change properties.
Now change “Command” from skype %U to env PULSE_LATENCY_MSEC=60 skype %U

That’s all. I hope this simple way has no error. For me it works and i hear clear skype sound notifications now, with no other side effects.

Switching off pulse control my audio icon in top-right corner disappeared – :frowning:

Greetings from Italy