How to do you enable Atheros AR9285 card in runlevel 3?


I am running openSuse 13.2 with Atheros AR9285 wireless card working just fine in runlevel 5 (ie gui interface). I want to upgrade 13.2 to Leap. Per upgrade’s instructions, i have to run the upgrade from the runlevel 3 (text mode +network). Unfortunately, I can not get my wireless card to work in runlevel 3…
Does anyone know how to configure wireless card to get it to work in runlevel 3?


Probably safer to switch to using wicked, rather than NetworkManager? Configure via YaST or via the ncurses version in a VT

Just press alt+F1 to switch to a VT (tty1), login as root, check you wireless connection then run the init 3 command and check again.

Thanks for reply. I am not too sure what you meant in your first line, but I did follow the instructions in your 2nd line:
went to shell, switched to root, pinged - works,
did the init 3, pinged - does not work.
did the ifconfig, the ipaddress is not assigned to my wlo2 adapter, but other info is in there.

Regarding your very first line, what exactly should I be configuring via YaST?


YaST->System->Network Settings on the Global Options in the dropdown select wicked, then on the overview, select your wireless device and hit edit to configure as required on the next screens.

Thanks!! I set the wireless to DCHP under wicked and it worked like a charm in runlevel 3.
Now happily running Leap.

Thanks a lot!!