how to do nothing when I open laptop lid by sysfs

Hi, on my laptop using KDE I would like to not resume from suspend when I open the lid.
I asked it in 2018 in this post
the solution proposed by deano ferrari here worked doing this

this file:/etc/tmpfiles.d/disable-lid-wakeup.conf
with into this:
w /proc/acpi/wakeup - - - - LID

but after this post
I thought that it maybe solved by sysfs using a command similar that the one I used in the post.
something like

sudo sh -c "echo disabled > /sys/something/somewhere/some/x-x/power/wakeup"

where can I individuate the something/somewhere/some/x-x ???

Sorry to have said a wrong thing, I tried

this file:/etc/tmpfiles.d/disable-lid-wakeup.confwith into this:
w /proc/acpi/wakeup - - - - LID

but it doesn’t work here>:)

I also tried this:
in /proc/acpi/wakeup I look for “LID” and find:
Device S-state Status Sysfs node

LID0 S3 *enabled platform:PNP0C0D:00

I look for in /sys/bus/acpi/devices/ a folder or a file “PNP0C0D:00”
in the folder there is a folder “power”
I look for a file “wakeup”
I find and inside there is written “enabled”
I think I should change in disabled

I do like in the past a grep in /sys

pla@pla4-TW:~> grep . /sys/bus/acpi/devices/PNP0C0D:00/power/wakeupenabled

I try to disable in that way

pla@pla4-TW:~> sudo sh -c "echo disabled > /sys/bus/acpi/devices/PNP0C0D:00/power/wakeup"
[sudo] password for root:

I control

pla@pla4-TW:~> grep . /sys/bus/acpi/devices/PNP0C0D:00/power/wakeup

…but it doesn’t works:| also after reboot it results enabled

pla@pla4-TW:~> grep . /sys/bus/acpi/devices/PNP0C0D:00/power/wakeupenabled

where I did wrong??

Have you investigated the logind settings (/etc/systemd/logind.conf and man logind.conf)?

I investigated a little,
in /etc/systemd/logind.conf the default are:


and they are commented with #

I tried to change these:


one by one and both

and also added this


after each change I saved the file and rebooted,
but it didn’t work, when I open the lid the laptop is always resumed

also I deleted /etc/systemd/logind.conf to restore to defaults as the instructions on the file says

# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.

but the file wasn’t restored at all

other ideas?