How to display asterisks for password chars on console login (not sudo!)

how can i make password characters shown as asterisks when doing a terminal login? I am not talking about the password when doing a “sudo”, which is done via visudo!

Basically i just want to see how many characters i type. I have a strange problem with one of my (tumbleweed) pcs after a kernal upgrade, in such cases i have to reinstall the proprietary NVIDIA graphic driver to make the GUI working again. The problem is, that on this system in such cases the terminal kind of flickers, which results in about 25% of all keyboard presses getting lost. So to reinstall the graphic driver and thus redering the system working again i need to login as root first (in a command line terminal), but not knowing if the current password character was received or not makes this a real pain and can need up to a few hundreds tries to get it working.

AFAIK this is not possible. The console and also the terminal emulators (like xterm and Konsole) emulate (no surprise) the old TTY (and more modern asynchronous terminals). On asynchronous lines you can have Echo on or off. Normally Echo was on, that is the system echoed back what it received from you. At the same time the terminal was configured to print (or show on glass TTYs and emulators) nothing. This gave some confidence that what you typed was received correct at the other end.
For passwords echo is switched off, thus the system sends nothing back. And as the the terminal also shows nothing, the password is kept secret. Thus a rather basic function of the emulator.

In that case you need to boot without activating any graphics modules and enter text login only. This will avoid any strange flickering.

Place your cursor line in grub over your tumbleweed entry and press ‘e’

There search the kernel line with the kernel …] splash=silent option.

There change it to splash=verbose and append to the end of that line: nomodeset 3

Then boot by pressing F10

This will boot to runlevel 3 text-only. There you install your nvidia driver and just reboot.