How to disable update for a package

Hello,

I have an application here that has some incompatibilities with java 1.6.0_11 and for this reason I must use java 1.6.0_7.

The problem is that everyday the update applet shows me a message telling to update this package.

Is there a way to disable the update of this package without removing OpenSUSE Update Repository?

Thanks in advance,

Tulio Magno

Goto yast > oline update > right click the update in question and select " protect " from the menu.

Hello BoloMarkIII,

Thanks for your help.

I tried this, but I’m still getting these messages…

Best regards,

Tulio Magno

Hi
Have a read of this post user lornix has a fix;
How
to lock a package permanently?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-pae
up 8:23, 1 user, load average: 0.32, 0.29, 0.21
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Hi malcolmlewis,

Thanks for your help.
I tried that. Firstly I changed the backend to zypper (I think the default in OpenSUSE 11.1 is PackageKit) to show that special tab.

But I’m still receiving these messages from kupdateapplet.

I think it’s really necessary to create an easy option in kupdateapplet to block some updates.

In openSUSE 11.3, the update applet still tries to update locked packages (i.
e. installed packages that are marked as protected in Yast Software Management)
but marking patches as taboo in Yast Online Update works (patches marked as
taboo are not shown in the update applet). See
https://bugzilla.novell.com/show_bug.cgi?id=544466

It works!
Thank you.